Bug 508308 - package-kit applet issues unclear notices.
package-kit applet issues unclear notices.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 09:40 EDT by Ralf Corsepius
Modified: 2009-09-13 04:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-13 04:32:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the incident (16.38 KB, image/png)
2009-06-26 09:40 EDT, Ralf Corsepius
no flags Details

  None (edit)
Description Ralf Corsepius 2009-06-26 09:40:43 EDT
Created attachment 349551 [details]
screenshot of the incident

Description of problem:
After today's FC11 update, package-kit's applet greeted me with:

"You need to log out and log back in
Package: dovecot, dovecot, dovecot, audit and audit"

The log out/log in part of this messages is clear, but I do not understand what this message is meant to tell me.

Version-Release number of selected component (if applicable):
# rpm -qa 'Package*'
PackageKit-yum-0.4.8-1.fc11.x86_64
PackageKit-gtk-module-0.4.8-1.fc11.i586
PackageKit-yum-plugin-0.4.8-1.fc11.x86_64
PackageKit-gstreamer-plugin-0.4.8-1.fc11.x86_64
PackageKit-0.4.8-1.fc11.x86_64
PackageKit-qt-0.4.8-1.fc11.x86_64
PackageKit-gtk-module-0.4.8-1.fc11.x86_64
PackageKit-glib-0.4.8-1.fc11.x86_64
Comment 1 Richard Hughes 2009-06-26 10:09:34 EDT
What about "The following packages were installed, and require a reboot to work correctly"
Comment 2 Ralf Corsepius 2009-06-26 10:28:51 EDT
(In reply to comment #1)
> What about "The following packages were installed, and require a reboot to work
> correctly"  

Yes, this would be better.

Nevertheless, this raises further questions:

- The message was talking about "log in/log out" not about "reboot"
I am inclined to consider this to be a packagers' mistake, but ..., could be a bug in package kit, also.

log-in/log-out would not help in case of dovecot or audit, restarting the corresponding services rsp. the "big gun" (reboot) would do so.

- Why are those packages listed multiple times?

- Is this message actually wanting to tell "you need to restart the dovecot and auditd services"? In this case, at least "audit" would be wrong, because the service is called "auditd".
Comment 3 Richard Hughes 2009-06-30 09:53:33 EDT
(In reply to comment #2)
> - The message was talking about "log in/log out" not about "reboot"
> I am inclined to consider this to be a packagers' mistake, but ..., could be a
> bug in package kit, also.

Yes, I fixed a bug in PK a few days ago as it was ignoring the reboot flag in the bodhi metadata.

> - Why are those packages listed multiple times?

Due to a bug in the restart cache generation. I think I've fixed this now.

I've committed this to gnome-packagekit too:

commit f5d1664eb894342dc5a145dc7fe8af9f7a29ecaf
Author: Richard Hughes <richard@hughsie.com>
Date:   Tue Jun 30 14:50:02 2009 +0100

    Use better wording when a package sent RequireRestart

I'll do a new rawhide snapshot next Monday, and hopefully it'll be better then. Thanks.

Richard.
Comment 4 Steven M. Parrish 2009-09-12 19:51:34 EDT
Richard has this issue been resolved?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Richard Hughes 2009-09-13 04:32:08 EDT
Yup, thanks.

Note You need to log in before you can comment on or make changes to this bug.