Bug 508360 - traceback on yum whatprovides
traceback on yum whatprovides
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 505831 508620 514704 524449 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 13:44 EDT by Mamoru TASAKA
Modified: 2014-01-21 18:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 10:49:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2009-06-26 13:44:42 EDT
Description of problem:
Well,
=====================================================================
[root@localhost i586]# env LANG=ja_JP.UTF-8 yum -d 10 '--disablerepo=*' whatprovides /usr/bin/xscreensaver
プラグイン「dellsysidplugin2」を読み込んでいます
Running "postconfig" handler for "dellsysidplugin2" plugin
Config time: 0.964
Running "init" handler for "dellsysidplugin2" plugin
repo time: 0.000
Yum Version: 3.2.23
COMMAND: yum -d 10 --disablerepo=* whatprovides /usr/bin/xscreensaver 
Installroot: /
Ext Commands:

   /usr/bin/xscreensaver
Setting up Package Sacks
pkgsack time: 0.001
ローカルの RPMDB を読み込んでいます
rpmdb time: 0.038
依存性の pkgSack を検索しています: /usr/bin/xscreensaver
0 個のパッケージを検索しています
1:xscreensaver-base-5.08-10.fc12.i586 : A minimal installation of xscreensaver
リポジトリー  : installed
Matched from:
Traceback (most recent call last):
  File "/usr//bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 178, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 353, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 559, in doCommand
    return base.provides(extcmds)
  File "/usr/share/yum-cli/cli.py", line 839, in provides
    callback_has_matchfor=True)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 2029, in searchPackageProvides
    callback(po, tmpvalues, args)
  File "/usr/share/yum-cli/output.py", line 870, in matchcallback_verbose
    return self.matchcallback(po, values, matchfor, verbose=True)
  File "/usr/share/yum-cli/output.py", line 864, in matchcallback
    print self.fmtKeyValFill(key, item)
  File "/usr/lib/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe3 in position 0: ordinal not in range(128)

Version-Release number of selected component (if applicable):
# rpm -q yum rpm
yum-3.2.23-8.fc12.noarch
rpm-4.7.0-8.fc12.i586

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.


Expected results:
Something like:
==============================================================
[root@localhost i586]# env LANG=C yum -d 10 '--disablerepo=*' whatprovides /usr/bin/xscreensaver
Loading "dellsysidplugin2" plugin
Running "postconfig" handler for "dellsysidplugin2" plugin
Config time: 0.496
Running "init" handler for "dellsysidplugin2" plugin
repo time: 0.000
Yum Version: 3.2.23
COMMAND: yum -d 10 --disablerepo=* whatprovides /usr/bin/xscreensaver 
Installroot: /
Ext Commands:

   /usr/bin/xscreensaver
Setting up Package Sacks
pkgsack time: 0.001
Reading Local RPMDB
rpmdb time: 0.034
Searching pkgSack for dep: /usr/bin/xscreensaver
Searching 0 packages
1:xscreensaver-base-5.08-10.fc12.i586 : A minimal installation of xscreensaver
Repo        : installed
Matched from:
Other       : Provides-match: /usr/bin/xscreensaver
Comment 1 seth vidal 2009-06-29 16:26:14 EDT
*** Bug 508620 has been marked as a duplicate of this bug. ***
Comment 2 James Antill 2009-07-07 10:49:51 EDT
Fixed in commit: b05bda414682bce0eb145e52988e3d63268164ed
Comment 3 James Antill 2009-07-27 16:58:35 EDT
*** Bug 505831 has been marked as a duplicate of this bug. ***
Comment 4 James Antill 2009-07-30 11:43:45 EDT
*** Bug 514704 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Wickert 2009-09-20 15:25:09 EDT
*** Bug 524449 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.