Bug 508381 - frequent DB transaction rollbacks from xmlserver
frequent DB transaction rollbacks from xmlserver
Status: CLOSED WONTFIX
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other (Show other bugs)
RHN Stable
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike Orazi
Red Hat Network Quality Assurance
US=100895
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 16:06 EDT by Chris Duryee
Modified: 2013-01-10 05:34 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 16:36:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Duryee 2009-06-26 16:06:29 EDT
Description of problem:

The following bit of SQL is getting rolled back frequently by xmlservers:

select s.id, s.secret from rhnServer s where s.id = :p1

I'm not an Oracle expert, so I'm not sure why this creates a transaction in the first place since it's only a SELECT. Don can provide more detail.

Anyway, what's happening is that the rollback isn't occurring explicitly, but instead the DB holds the transaction open and eventually performs an implicit rollback. The XML servers need to clean up the transaction on their own, because while the transaction is open, it holds memory latches.

Here are a few sample values for the bind variable:

1013949796
1012301731
1013086498
1013682246

Let me know if you need any additional detail.
Comment 1 James Bowes 2009-06-26 17:04:16 EDT
Call stack:
server.rhnhandler.rhnHandler.auth_system()
server.rhnServer.__init__.get()
server.rhnServer.server_certificate.Certificate.valid()
server.rhnServer.server_lib.getServerSecret()
server.rhnServer.server_lib.getServerID()

auth_system is called from our various xmlrpc handlers.
Comment 2 Denise Hughes 2009-07-27 16:36:08 EDT
This was actually not a problem with xmlserver.  The problem was fixed elsewhere.  Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.