Bug 508385 - libburn-devel multilib conflicts
libburn-devel multilib conflicts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libburn (Show other bugs)
17
All Linux
low Severity medium
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 16:20 EDT by Philippe Troin
Modified: 2012-09-12 03:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 03:03:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2009-06-26 16:20:11 EDT
I am aware of the other bugs which have been closed, but I cannot reopen them.

Description of problem:

yum install libburn-devel.i586 libburn-devel.x86_64

yields:

Transaction Check Error:
  file /usr/share/doc/libburn-devel-0.6.0/html/annotated.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/classes.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/comments-source.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/comments.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/files.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/functions.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/functions_vars.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals_0x62.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals_0x63.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals_0x64.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals_0x6c.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals_0x6d.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals_0x73.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals_defs.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals_enum.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals_eval.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals_func.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals_type.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/globals_vars.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/graph_legend.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/index.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/libburn_8h-source.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/libburn_8h.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/libburner_8c-source.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/libburner_8c.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/structburn__drive__info.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/structburn__multi__caps.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/structburn__progress.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/structburn__source.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/structburn__speed__descriptor.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64
  file /usr/share/doc/libburn-devel-0.6.0/html/structburn__toc__entry.html from install of libburn-devel-0.6.0-3.fc11.i586 conflicts with file from package libburn-devel-0.6.0-3.fc11.x86_64


Version-Release number of selected component (if applicable):
libburn-devel-0.6.0-3.fc11

Please fix it.  Maybe by spinning a new doc package out.  Or controlling better the doc generation.

Phil.
Comment 1 Fedora Admin XMLRPC Client 2010-04-09 03:31:25 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Bug Zapper 2010-04-27 11:17:00 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2010-06-28 09:19:02 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 4 Philippe Troin 2012-06-12 18:54:49 EDT
Still there in F17:

# yum install libburn-devel
Loaded plugins: changelog, downloadonly, priorities, remove-with-leaves, show-
              : leaves, tsflags
16 packages excluded due to repository priority protections
Package libburn-devel-1.2.2-1.fc17.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package libburn-devel.i686 0:1.2.2-1.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package               Arch         Version               Repository       Size
================================================================================
Installing:
 libburn-devel         i686         1.2.2-1.fc17          updates         218 k

Transaction Summary
================================================================================
Install  1 Package

Total size: 218 k
Installed size: 1.8 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  file /usr/share/doc/libburn-devel-1.2.2/html/annotated.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/classes.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/comments.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/comments_source.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/files.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/functions.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/functions_vars.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals_0x62.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals_0x63.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals_0x64.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals_0x6c.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals_0x6d.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals_0x73.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals_defs.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals_enum.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals_eval.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals_func.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals_type.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/globals_vars.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/index.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/libburn_8h.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/libburn_8h_source.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/libburner_8c.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/libburner_8c_source.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/structburn__drive__info.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/structburn__multi__caps.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/structburn__progress.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/structburn__source.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/structburn__speed__descriptor.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64
  file /usr/share/doc/libburn-devel-1.2.2/html/structburn__toc__entry.html from install of libburn-devel-1.2.2-1.fc17.i686 conflicts with file from package libburn-devel-1.2.2-1.fc17.x86_64

Error Summary
-------------

[2]    12178 exit 1     noglob yum install libburn-devel
Comment 5 Honza Horak 2012-09-12 03:03:21 EDT
It seems like doxygen has changed default footer content and removed generation time from html pages, which was actually the problem. As a consequence, libburn-devel-1.2.2 should have been the last build with conflict issues and libburn-devel-1.2.4, which is currently available, has no such problems. Feel free to re-open this bug if needed.

Note You need to log in before you can comment on or make changes to this bug.