Bug 50841 - endless loop on bad package on cd
endless loop on bad package on cd
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 52216 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-03 16:10 EDT by Donald Harper
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-03 16:10:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald Harper 2001-08-03 16:10:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
When anaconda hits a package which could read (bad burn of CD), it gets
into an endless loop wanting user to press return because it could not read
a package.  Cannot continue, and reboot to a stable system.  LILO fails
after LI.

How reproducible:
Always

Steps to Reproduce:
1. Burn a bad CD. :)
2. Run upgrade.
3. Wear fingers out pressing return.
	

Actual Results:  endless dialog boxes w/ same message, saying press okay to
retry.

Expected Results:  It would be nice to see a skip or return to package
selection screen.

Additional info:
Comment 1 Brent Fox 2001-08-06 11:55:51 EDT
It's always a good idea to check the md5sum before you burn the cd.  Allowing
you to skip the package is a bad idea, becuase we have no way of knowing at that
point what other packages depend on that one.  It could be glibc or the kernel,
and allowing the user to click "Skip" there would be very bad.  

Also, allowing you to go back to the package selection screen isn't good either.
 I mean, it's already clear that the cd is bad at that point...the idea of
unselecting that one package and still doing the install with a known bad cd is
probably not the smart way to go.  Also, there's no guarantee that only one
package is damaged.  Imagine if you went back and unselected that package and
then went forward again only to find out that another package further down the
install list was damaged too.  You could repeat that cycle for hours...

It's much better to make sure the cd is good before you do the install.  It
makes everything easier.  :)
Comment 2 Brent Fox 2001-08-21 15:47:41 EDT
*** Bug 52216 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.