Bug 508415 - Thunderbird 3.0b2 confused by News accounts with ports other than 119
Thunderbird 3.0b2 confused by News accounts with ports other than 119
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
11
i586 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 18:44 EDT by Jason Merrill
Modified: 2018-04-11 08:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-04 22:58:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 500809 None None None Never

  None (edit)
Description Jason Merrill 2009-06-26 18:44:51 EDT
Description of problem:

Thunderbird 3.0b2 fails to handle a News account with a server port other than 119, which Thunderbird 2 was happy with.

Version-Release number of selected component (if applicable):

thunderbird-3.0-2.3.beta2.fc11.i586

How reproducible:

Always

Steps to Reproduce:
1. Set up SSH tunnel to access NNTP server through localhost:8119
2. Make Thunderbird news account using localhost:8119
3. Open a newsgroup
4. Try to open a message
  
Actual results:

A dialog box saying "The connection was refused when attempting to contact localhost:119."

Expected results:

The message.

Additional info:

This bug makes it impossible for me to read this news account using Thunderbird.
Comment 1 Matěj Cepl 2009-06-27 09:23:44 EDT
Sorry, just works for me.

This is how I tried to reproduce it:

1) Set up new NNTP account with newsgroup server localhost
2) Change in Edit/Account Settings/<name>/Server Settings port to 8119
3) Run
ssh -N -L 8119:news.gmane.org:119 <some-other-computer>
4) Subscribe in TB to gmane.test
5) Post the message

And it is here http://article.gmane.org/gmane.test/5260

Did you do everything exactly as shown above? (Especially, in account creation dialog you should NOT put localhost:8119, but change the port number in the account properties later).
Comment 2 Jason Merrill 2009-07-17 16:55:35 EDT
The problem for me was with reading, not posting.  But in any case, it's fixed in the current development tree, so it should be fine in b3.
Comment 3 Jason Merrill 2010-01-04 22:58:52 EST
Closing, fixed in thunderbird 3.0.

Note You need to log in before you can comment on or make changes to this bug.