Bug 508469 - console switching fails with nouveau driver
console switching fails with nouveau driver
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 10:31 EDT by Sebastian Krämer
Modified: 2009-07-21 17:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 513076 (view as bug list)
Environment:
Last Closed: 2009-07-21 17:11:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of 'cat /var/log/messages|grep -i nouveau' (83.24 KB, text/plain)
2009-06-27 10:31 EDT, Sebastian Krämer
no flags Details
Xorg log file (81.15 KB, text/plain)
2009-07-21 06:54 EDT, Sebastian Krämer
no flags Details
Xorg log: nouveau driver + modeset=1 (5.15 KB, text/plain)
2009-07-21 17:05 EDT, Sebastian Krämer
no flags Details
Xorg log: nouveau driver + vga=... (41.09 KB, text/plain)
2009-07-21 17:06 EDT, Sebastian Krämer
no flags Details
Xorg log: nvidia driver + modeset=1 (5.15 KB, text/plain)
2009-07-21 17:09 EDT, Sebastian Krämer
no flags Details
Xorg log: nouveau driver (39.84 KB, text/plain)
2009-07-21 17:10 EDT, Sebastian Krämer
no flags Details

  None (edit)
Description Sebastian Krämer 2009-06-27 10:31:33 EDT
Created attachment 349659 [details]
output of 'cat /var/log/messages|grep -i nouveau'

Description of problem: I have a fresh install of f11. When I tried to do a switch from X to console (ctrl-alt-f2), I got a black screen, then it switched right back to X. It seemed quite impossible to get a working console outside X.


Version-Release number of selected component (if applicable):
# yum info xorg-x11-drv-nouveau
Loaded plugins: refresh-packagekit
Installed Packages
Name       : xorg-x11-drv-nouveau
Arch       : x86_64
Epoch      : 1
Version    : 0.0.12
Release    : 36.20090514git9656762.fc11

How reproducible:
Always.

Additional info:
# lspci |grep VGA
01:00.0 VGA compatible controller: nVidia Corporation GeForce 9300M GS (rev a1)

I'll add parts of my system log.

I switched to kmod-nvidia which got me rid of that problem. If I knew how to enable nouveau temporarily, I'd be willing to test other nouveau releases for this bug.
Comment 1 Adam Williamson 2009-07-20 20:37:58 EDT
Just moving /etc/X11/xorg.conf to a different name and rebooting should be sufficient to 'enable nouveau temporarily'. Can we get your Xorg.0.log, just on the off chance it contains something useful? Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Sebastian Krämer 2009-07-21 06:52:16 EDT
(In reply to comment #1)
> Just moving /etc/X11/xorg.conf to a different name and rebooting should be
> sufficient to 'enable nouveau temporarily'.

Unfortunately it wasn't. I removed xorg-x11-drv-nvidia, rm'ed /etc/X11/xorg.conf and rebootet, which then forced nouveau to load.

> Can we get your Xorg.0.log, just on
> the off chance it contains something useful? Thanks!

Sure, I'll create an attachment in a sec.
Comment 3 Sebastian Krämer 2009-07-21 06:54:16 EDT
Created attachment 354457 [details]
Xorg log file

Note that in the meantime, nouveau-version updated to 40.20090528git0c17b87.fc11.
Comment 4 Ben Skeggs 2009-07-21 08:39:18 EDT
We currently don't have a great deal of control over restoring the console unfortunately, relying on the video BIOS to do the work.

Were you by any chance using a vga= parameter in your boot options?  The mode ID that we get back from the VBIOS for the console is rather odd.

If you do want to use the nouveau driver, you'll probably have more success with getting a console by booting with nouveau.modeset=1 added to your kernel options.  We have quite a bit more control of what happens in the kernel modesetting path.
Comment 5 Sebastian Krämer 2009-07-21 08:55:47 EDT
(In reply to comment #4)
> Were you by any chance using a vga= parameter in your boot options?  The mode
> ID that we get back from the VBIOS for the console is rather odd.

Yes, I'm using vga=0x361. IIRC it was necessary for plymouth to work (it definitely was for f10..).

> If you do want to use the nouveau driver, you'll probably have more success
> with getting a console by booting with nouveau.modeset=1 added to your kernel
> options.  We have quite a bit more control of what happens in the kernel
> modesetting path.

I added that (thanks for the hint) but for now I'll use the nvidia module.

If needed I can retry previous steps with modeset=1 enabled.
Comment 6 Adam Williamson 2009-07-21 13:54:16 EDT
it would be useful indeed to see if it works with nouveau.modeset=1, and get the X log. thanks! maybe also without nouveau.modeset=1 but also without the vga= parameter.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Sebastian Krämer 2009-07-21 17:01:12 EDT
Ok. First off: modeset=1 did rather bad than good, I found other bugs..

Good news is that the initial bug is probably fixed by the driver update (since I opened the bug). I'll create some attachments and add comments there.
Comment 8 Sebastian Krämer 2009-07-21 17:05:00 EDT
Created attachment 354585 [details]
Xorg log: nouveau driver + modeset=1

X won't work at all. All I get is a scrambled image which is a mix of my vendor's bootup bios screen, a console login prompt and some blueish-greenish area. It's still possible to login to X, you just won't see any change on screen.

The ttys only show a cursor, no login prompts or anything, just a blinking cursor. Console switching however works ;)
Comment 9 Sebastian Krämer 2009-07-21 17:06:25 EDT
Created attachment 354586 [details]
Xorg log: nouveau driver + vga=...

Console switch ok. .. and X okay too!  (This is where you could close this bug I guess.)
Comment 10 Sebastian Krämer 2009-07-21 17:09:14 EDT
Created attachment 354587 [details]
Xorg log: nvidia driver + modeset=1

This was rather an accident where I hadn't uninstalled the nvidia driver but changed the boot parameters already. Might be unimportant, I'm just adding this for sake of completeness.

Lots of flicker. No X. Console switching works.
Comment 11 Sebastian Krämer 2009-07-21 17:10:51 EDT
Created attachment 354589 [details]
Xorg log: nouveau driver

X works, console switching works. No plymouth.
Comment 12 Adam Williamson 2009-07-21 17:11:45 EDT
If it works now with default options, we can close the bug. However, it would be great if you could file a new one for the failure of nouveau.modeset=1 ; we want to make sure mode setting works on as many chips as possible in preparation for enabling it by default in future. Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Sebastian Krämer 2009-07-21 17:29:51 EDT
No problem, already filed as bug #513076 .

Note You need to log in before you can comment on or make changes to this bug.