Bug 508514 - missing import in dhcp plugin
missing import in dhcp plugin
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Stokes
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-28 03:49 EDT by Dan Kenigsberg
Modified: 2009-06-29 10:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 10:25:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add missing import os (339 bytes, patch)
2009-06-28 03:49 EDT, Dan Kenigsberg
no flags Details | Diff

  None (edit)
Description Dan Kenigsberg 2009-06-28 03:49:02 EDT
Created attachment 349691 [details]
add missing import os

every execution of sosreport shows "plugin dhcp.py does not install, skipping". This is becuase the new dhcp plugin uses os.path before importing it.
Comment 1 Adam Stokes 2009-06-29 09:25:12 EDT
what version are you reporting this against?
Comment 2 Dan Kenigsberg 2009-06-29 09:49:35 EDT
sos-1.7-9.22.el5
Comment 3 Adam Stokes 2009-06-29 09:58:10 EDT
Hi,

This is addressed in sos-1.7-9.24.el5 so we don't really need this BZ open. Have you had a chance to test the latest version?

Thanks,
Adam
Comment 4 Dan Kenigsberg 2009-06-29 10:25:29 EDT
no, I wasn't aware that sos-1.7-9.24.el5 is available, it is not yet in dist-5E-U4-pending. I'm closing this bug since it's already solved.

By the way, it would be nice if you update the %changelog section.

Note You need to log in before you can comment on or make changes to this bug.