Bug 508579 - kernel BUGs with SierraWireless AirCArd U875U / sierra module
kernel BUGs with SierraWireless AirCArd U875U / sierra module
Status: CLOSED DUPLICATE of bug 500954
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-28 16:01 EDT by Sergey Bostandzhyan
Modified: 2009-06-30 12:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 12:26:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergey Bostandzhyan 2009-06-28 16:01:04 EDT
Description of problem:

when connecting the Sierra Wireless AirCard 875U I observe two kernel BUGs in the log. It is still possible to use the card, however it is sometimes very difficult to actually connect to the ISP, sometimes the USB connection to the card gets lost and the old /dev/USB* nodes remain. Even when the card is then unplugged, the sierra module can not be unloaded anymore.

I also noticed that it is extremely difficult to get a connection using NetworkManager, manually calling wvdial or gnome-ppp provides far better results.

Version-Release number of selected component (if applicable):

2.6.29.5-191.fc11.x86_64

How reproducible:

always


Steps to Reproduce:
1. do a fresh boot, watch log
2. connect the card
3. try to go online via the card (i.e. using wvdial, gnome-ppp or NetworkManager)
  

Additional info:

usb 6-2: new full speed USB device using uhci_hcd and address 2
usb 6-2: New USB device found, idVendor=1199, idProduct=6812
usb 6-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 6-2: Product: Mini Card
usb 6-2: Manufacturer: Sierra Wireless, Incorporated
usb 6-2: configuration #1 chosen from 1 choice
usbcore: registered new interface driver usbserial
USB Serial support registered for generic
usbcore: registered new interface driver usbserial_generic
usbserial: USB Serial Driver core
USB Serial support registered for Sierra USB modem
sierra 6-2:1.0: Sierra USB modem converter detected
usb 6-2: Sierra USB modem converter now attached to ttyUSB0
usb 6-2: Sierra USB modem converter now attached to ttyUSB1
usb 6-2: Sierra USB modem converter now attached to ttyUSB2
usbcore: registered new interface driver sierra
sierra: v.1.3.2:USB Driver for Sierra Wireless USB modems
ACPI: EC: GPE storm detected, transactions will use polling mode
BUG: sleeping function called from invalid context at kernel/mutex.c:88
in_atomic(): 1, irqs_disabled(): 1, pid: 0, name: swapper
Pid: 0, comm: swapper Not tainted 2.6.29.5-191.fc11.x86_64 #1
Call Trace:
 <IRQ>  [<ffffffff8103fd8f>] __might_sleep+0x10b/0x110
 [<ffffffff813aaa0e>] mutex_lock+0x22/0x38
 [<ffffffff8122e6ba>] reset_buffer_flags+0x56/0xdf
 [<ffffffff8122e75d>] n_tty_flush_buffer+0x1a/0x77
 [<ffffffff8122eb69>] n_tty_receive_buf+0x3af/0xe50
 [<ffffffffa01e2bd2>] ? __iwl_write32.clone.2+0xb0/0xbf [iwlcore]
 [<ffffffff81029f7f>] ? default_spin_lock_flags+0x9/0xe
 [<ffffffff813abe44>] ? _spin_unlock_irqrestore+0x2c/0x42
 [<ffffffff81230708>] ? tty_ldisc_try+0x3c/0x44
 [<ffffffff81231441>] flush_to_ldisc+0x10c/0x19f
 [<ffffffff81231524>] tty_flip_buffer_push+0x50/0x61
 [<ffffffffa02b5a30>] sierra_indat_callback+0x84/0xd5 [sierra]
 [<ffffffff8129f265>] usb_hcd_giveback_urb+0x8b/0xbf
 [<ffffffff812b86fd>] uhci_giveback_urb+0x10d/0x19a
 [<ffffffff812b9042>] uhci_scan_schedule+0x5b0/0x872
 [<ffffffff812baec7>] uhci_irq+0x130/0x149
 [<ffffffff8129ed87>] usb_hcd_irq+0x4c/0xab
 [<ffffffff8108befb>] handle_IRQ_event+0x38/0x74
 [<ffffffff8108d8a5>] handle_fasteoi_irq+0x91/0xde
 [<ffffffff81013ba4>] do_IRQ+0xd9/0x151
 [<ffffffff81011e93>] ret_from_intr+0x0/0x2e
 <EOI>  [<ffffffff81216404>] ? acpi_idle_enter_bm+0x28f/0x2de
 [<ffffffff812163fc>] ? acpi_idle_enter_bm+0x287/0x2de
 [<ffffffff812ec70f>] ? cpuidle_idle_call+0x8d/0xc2
 [<ffffffff810102a1>] ? cpu_idle+0x68/0xb3
 [<ffffffff813a5e3c>] ? start_secondary+0x199/0x19e
wlan0: direct probe to AP 00:0f:b5:78:26:ec try 1
usb 5-2: USB disconnect, address 2
btusb_intr_complete: hci0 urb ffff8801375aa480 failed to resubmit (19)
btusb_bulk_complete: hci0 urb ffff88013bb81f00 failed to resubmit (19)
btusb_bulk_complete: hci0 urb ffff88013748c540 failed to resubmit (19)
btusb_send_frame: hci0 urb ffff88012dca6d80 submission failed
PPP generic driver version 2.4.2
PPP Deflate Compression module registered
CE: hpet increasing min_delta_ns to 15000 nsec
usb 6-2: USB disconnect, address 2
sierra ttyUSB0: Sierra USB modem converter now disconnected from ttyUSB0
sierra ttyUSB1: Sierra USB modem converter now disconnected from ttyUSB1
sierra ttyUSB2: Sierra USB modem converter now disconnected from ttyUSB2
sierra 6-2:1.0: device disconnected
usb 6-2: new full speed USB device using uhci_hcd and address 3
usb 6-2: New USB device found, idVendor=1199, idProduct=6812
usb 6-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 6-2: Product: Mini Card
usb 6-2: Manufacturer: Sierra Wireless, Incorporated
usb 6-2: configuration #1 chosen from 1 choice
sierra 6-2:1.0: Sierra USB modem converter detected
usb 6-2: Sierra USB modem converter now attached to ttyUSB3
usb 6-2: Sierra USB modem converter now attached to ttyUSB4
usb 6-2: Sierra USB modem converter now attached to ttyUSB5
BUG: unable to handle kernel NULL pointer dereference at 0000000000000048
IP: [<ffffffffa02b5807>] sierra_close+0x26/0x9e [sierra]
PGD 128d1c067 PUD 128d86067 PMD 0 
Oops: 0002 [#1] SMP 
last sysfs file: /sys/devices/pci0000:00/0000:00:1d.1/usb6/6-2/idProduct
CPU 0 
Modules linked in: ppp_deflate zlib_deflate ppp_async crc_ccitt ppp_generic slhc sierra usbserial fuse usb_storage rfcomm sco bridge stp llc bnep l2cap sunrpc ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath uinput snd_hda_codec_atihdmi btusb snd_hda_codec_realtek arc4 bluetooth ecb snd_hda_intel snd_hda_codec video iwlagn i2c_i801 iwlcore uvcvideo snd_hwdep atl1e lib80211 snd_pcm pcspkr mac80211 serio_raw snd_timer videodev snd joydev v4l1_compat v4l2_compat_ioctl32 acer_wmi soundcore cfg80211 snd_page_alloc wmi iTCO_wdt iTCO_vendor_support output sha256_generic cbc aes_x86_64 aes_generic dm_crypt radeon drm i2c_algo_bit i2c_core [last unloaded: microcode]
Pid: 2752, comm: wvdial Not tainted 2.6.29.5-191.fc11.x86_64 #1 Aspire 8920
RIP: 0010:[<ffffffffa02b5807>]  [<ffffffffa02b5807>] sierra_close+0x26/0x9e [sierra]
RSP: 0018:ffff880128d49d38  EFLAGS: 00010292
RAX: ffffffffa02b7340 RBX: ffff88012d5ea400 RCX: 0000000000000000
RDX: ffff880128cbf780 RSI: ffff88012d5ea400 RDI: ffff88013445c000
RBP: ffff880128d49d68 R08: 0000000000000000 R09: 0000000000000004
R10: 00007f69a05f93f0 R11: 0000000000000246 R12: 0000000000000000
R13: ffff880128cbf780 R14: ffff88013445c000 R15: ffff88012d0256c0
FS:  00007f69a05fb7d0(0000) GS:ffffffff817b7000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 0000000000000048 CR3: 0000000128d93000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process wvdial (pid: 2752, threadinfo ffff880128d48000, task ffff88012d07ae00)
Stack:
 ffff88012d5ea490 ffff88012d5ea400 ffff88013445c000 ffff880128cbf780
 ffff88012d0256c0 ffff88012d5ea490 ffff880128d49db8 ffffffffa03b0cd4
 ffff880128d49db8 ffffffffa02b7900 ffff880128d49db8 ffff88013445c000
Call Trace:
 [<ffffffffa03b0cd4>] serial_close+0x9d/0x156 [usbserial]
 [<ffffffff8122c3d2>] tty_release_dev+0x198/0x49a
 [<ffffffff810e00bd>] ? user_path_at+0x64/0x93
 [<ffffffff810e9e5c>] ? mntput_no_expire+0x36/0x150
 [<ffffffff8105c8d7>] ? autoremove_wake_function+0x0/0x39
 [<ffffffff8122c6f2>] tty_release+0x1e/0x29
 [<ffffffff810d608c>] __fput+0xf9/0x1a0
 [<ffffffff810d614d>] fput+0x1a/0x1c
 [<ffffffff810d348d>] filp_close+0x68/0x72
 [<ffffffff810d3543>] sys_close+0xac/0xea
 [<ffffffff8101133a>] system_call_fastpath+0x16/0x1b
Code: 5e 41 5f c9 c3 55 48 89 e5 41 57 41 56 41 55 41 54 53 48 83 ec 08 0f 1f 44 00 00 4c 8b 3e 4c 8b a6 88 02 00 00 49 89 fe 48 89 f3 <41> c7 44 24 48 00 00 00 00 41 c7 44 24 4c 00 00 00 00 49 83 3f 
RIP  [<ffffffffa02b5807>] sierra_close+0x26/0x9e [sierra]
 RSP <ffff880128d49d38>
CR2: 0000000000000048
---[ end trace 2afbf02d6ccca2be ]---
Comment 1 Chuck Ebbert 2009-06-30 12:26:06 EDT

*** This bug has been marked as a duplicate of bug 500954 ***

Note You need to log in before you can comment on or make changes to this bug.