Bug 508624 - setup-2.5.37-3.el4.noarch.rpm (RHEL-4.8) has introduced /etc/profile's glitch causing ksh to print stuff to stderr
setup-2.5.37-3.el4.noarch.rpm (RHEL-4.8) has introduced /etc/profile's glitch...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: setup (Show other bugs)
4.8
All Linux
high Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
BaseOS QE
: Regression, ZStream
: 510286 519539 (view as bug list)
Depends On:
Blocks: 616757
  Show dependency treegraph
 
Reported: 2009-06-29 04:06 EDT by Martin Osvald
Modified: 2016-06-17 17:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When logging in to the Korn shell (ksh), the shell output information about processes running in the background to standard error. This was caused by use of redirection syntax in the /etc/profile script which the Korn shell interpreter did not understand. This update changes the redirection syntax in the /etc/profile script such that the Korn shell no longer outputs extraneous information upon login.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-05 05:28:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Ondrej Vasik 2009-07-08 13:38:06 EDT
*** Bug 510286 has been marked as a duplicate of this bug. ***
Comment 20 errata-xmlrpc 2009-08-05 05:28:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1197.html
Comment 22 Radek Bíba 2009-08-27 02:30:09 EDT
*** Bug 519539 has been marked as a duplicate of this bug. ***
Comment 27 Douglas Silas 2010-07-26 10:38:05 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
When logging in to the Korn shell (ksh), the shell output information about processes running in the background to standard error. This was caused by use of redirection syntax in the /etc/profile script which the Korn shell interpreter did not understand. This update changes the redirection syntax in the /etc/profile script such that the Korn shell no longer outputs extraneous information upon login.

Note You need to log in before you can comment on or make changes to this bug.