Bug 508647 - Unable to update F11 x86_64 - kde packages conflict
Unable to update F11 x86_64 - kde packages conflict
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 06:25 EDT by Dan Yasny
Modified: 2014-01-21 18:10 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 17:04:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yasny 2009-06-29 06:25:28 EDT
Description of problem:
Unable to update F11 x86_64 -  kde packages conflict

Version-Release number of selected component (if applicable):


How reproducible:
`yum update`

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Transaction Check Error:
  file /usr/lib64/kde4/kcm_kdm.so from install of kdebase-workspace-4.2.4-3.fc11.x86_64 conflicts with file from package kdm-4.2.3-5.fc11.x86_64
  file /usr/share/kde4/services/kdm.desktop from install of kdebase-workspace-4.2.4-3.fc11.x86_64 conflicts with file from package kdm-4.2.3-5.fc11.x86_64


Expected results:
successful update

Additional info:
# rpm -q kdebase-workspace
kdebase-workspace-4.2.3-5.fc11.x86_64
# rpm -q kdm
kdm-4.2.3-5.fc11.x86_64
kdm-4.2.4-3.fc11.x86_64
Comment 1 Rex Dieter 2009-06-29 15:00:22 EDT
Not sure how you got 2 copies of kdm installed, but the older one definitely is the problem here.

Try
yum-complete-transaction

(from yum-utils)?
Comment 2 Rex Dieter 2009-06-29 15:04:54 EDT
On the other hand, kdebase-workspace shouldn't be including that file either.
Comment 3 Rex Dieter 2009-06-29 17:04:26 EDT
ok, fixed in rawhide. (kdebase-workspace-4.2.95-3)

Your fix, see comment #1
Comment 4 Dan Yasny 2009-06-30 05:18:00 EDT
great stuff, yum-complete-transaction worked, probably all is due to old clutter leftovers after F10>F11 upgrade

Note You need to log in before you can comment on or make changes to this bug.