Bug 508688 - noncomplete output of file executable
noncomplete output of file executable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: file (Show other bugs)
5.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Kaluža
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 09:53 EDT by Tomas Pelka
Modified: 2012-10-31 05:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: file-4.17-17
Doc Type: Bug Fix
Doc Text:
Cause: Magic pattern for PPD file detection was unfinished. Consequence: File ended in the middle of "version" word when detecting PPD files and printed only "ve" string. Fix: Magic pattern has been finished properly Result: File now prints "version" string properly including the version number.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:46:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ppd file (203.20 KB, application/octet-stream)
2009-07-03 10:02 EDT, Tomas Pelka
no flags Details
screenshot (10.98 KB, image/png)
2009-07-03 10:04 EDT, Tomas Pelka
no flags Details
a patch (588 bytes, patch)
2009-08-17 08:20 EDT, Daniel Novotny
no flags Details | Diff

  None (edit)
Description Tomas Pelka 2009-06-29 09:53:04 EDT
Description of problem:
File command give me not completed output, when I like to display info about PPD file.  

Version-Release number of selected component (if applicable):
file-4.17-16

How reproducible:
100%

Steps to Reproduce:
1. file cnr317ce1.ppd
  
Actual results:
cnr317ce1.ppd: PPD file, ve

Expected results:
/home/tom/Desktop/cnr317ce1.ppd: PPD file, version "4.3"

Additional info:
Comment 1 Daniel Novotny 2009-07-03 09:52:51 EDT
hello,
can you attach the PPD file?
Comment 2 Tomas Pelka 2009-07-03 10:02:22 EDT
Created attachment 350437 [details]
ppd file

Sure here it is.
Comment 3 Tomas Pelka 2009-07-03 10:04:17 EDT
Created attachment 350438 [details]
screenshot

Besides I'm attaching screenschot.
Comment 4 RHEL Product and Program Management 2009-07-21 04:22:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 Daniel Novotny 2009-08-17 08:20:55 EDT
Created attachment 357642 [details]
a patch

the PPD magic is broken in this version of file... here is the patch
Comment 6 Tomas Pelka 2009-08-18 05:07:36 EDT
Thanks Dan,
your patch works for me.
Comment 7 RHEL Product and Program Management 2009-11-06 13:41:32 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 11 RHEL Product and Program Management 2010-08-09 14:46:31 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 RHEL Product and Program Management 2011-05-31 09:55:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 18 Jan Kaluža 2012-01-05 04:56:16 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Magic pattern for PPD file detection was unfinished.

Consequence: File ended in the middle of "version" word when detecting PPD files and printed only "ve" string.

Fix: Magic pattern has been finished properly

Result: File now prints "version" string properly including the version number.
Comment 19 errata-xmlrpc 2012-02-21 00:46:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0201.html

Note You need to log in before you can comment on or make changes to this bug.