Bug 508725 - rhel3 i386 guests are not responding to shutdown command.
rhel3 i386 guests are not responding to shutdown command.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.4
i386 Linux
high Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 12:28 EDT by Gurhan Ozen
Modified: 2013-11-03 20:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 05:15:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2009-06-29 12:28:03 EDT
Description of problem:

  After installing guests on  ibm-x3650-03.ovirt.rhts.bos.redhat.com  box , the start/stop of guests failed and caused a lot of backtrace on the kernel console which can be seen at  
http://rhts.redhat.com/testlogs/69047/219177/1794321/8758678-console_dmesg--distribution-virt-start_stop-LOCALWATCHDOG.log

The system information can be seen at http://lab.rhts.bos.redhat.com/cgi-bin/rhts/system.cgi?id=1212

Version-Release number of selected component (if applicable):
RHEL5.4-Server-20090622.0 tree 

How reproducible:
Very.

Steps to Reproduce:
1. That particular box needs an access key. If you need it to be reserved let us know. 
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lalancette 2009-06-30 09:59:21 EDT
Gurhan,
     Are you sure about that?  It looks like somebody hit the Sysrq key for show a stack of all processes, and then hit one for all CPUs, which is why you saw stack traces for all processes and all CPUs :).  Can you get a more complete log from the time of bootup of the machine?

Chris Lalancette
Comment 2 Gurhan Ozen 2009-07-01 09:56:05 EDT
(In reply to comment #1)
> Gurhan,
>      Are you sure about that?  It looks like somebody hit the Sysrq key for
> show a stack of all processes, and then hit one for all CPUs, which is why you
> saw stack traces for all processes and all CPUs :).  Can you get a more
> complete log from the time of bootup of the machine?
> 
> Chris Lalancette  

 Ick. Sorry Chris.. What has happened was the tests timed out, the watchdog kicked in which sent Sysrq to get the stacks. 
  I'll retry this and see.
  Gurhan
Comment 3 Chris Lalancette 2009-07-09 07:41:50 EDT
Gurhan,
    Any thoughts/updates here?  I'd like to clear it out of the 5.4 queue if possible.

Chris Lalancette
Comment 4 Gurhan Ozen 2009-07-14 14:37:49 EDT
(In reply to comment #3)
> Gurhan,
>     Any thoughts/updates here?  I'd like to clear it out of the 5.4 queue if
> possible.
> 
> Chris Lalancette  

Sorry to get back late on this. 

Right now , it looks like rhel3 guests are not responding to the shutdown command , which is wreaking a havoc on the rest of the stuff. Will get back with more information soon.
Comment 5 Chris Lalancette 2009-07-15 03:52:47 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > Gurhan,
> >     Any thoughts/updates here?  I'd like to clear it out of the 5.4 queue if
> > possible.
> > 
> > Chris Lalancette  
> 
> Sorry to get back late on this. 
> 
> Right now , it looks like rhel3 guests are not responding to the shutdown
> command , which is wreaking a havoc on the rest of the stuff. Will get back
> with more information soon.  

Unfortunately, that's expected.  The way that shutdown works for guests is to write an entry into xenstore, which then fires a watch inside the guest, which then shuts down the guest.  In RHEL-3's case, without PV-on-HVM drivers, there's no concept of xenstore, so it can't be shutdown.

You have several options:
1)  Just "virsh destroy" your guests, and trust ext3 to save your data (should work most of the time)
2)  Install the PV-on-HVM drivers inside the guest, and make sure they get loaded at boot time.
3)  Setup up passwordless ssh with keys, and "ssh <guest> shutdown -h now"

Chris Lalancette
Comment 6 Gurhan Ozen 2009-07-15 15:18:16 EDT
Ok, I am going update the subject line of this bug to reflect what i have found. Basically rhel3 i386 guests aren't responding to shutdown command. It doesn't matter what hardware they are on . 

Chris, let me know if you need me to provide any additional information. I tried both xen and libvirt apis.

Note You need to log in before you can comment on or make changes to this bug.