Bug 50873 - pppd not logging WinNT4.0
Summary: pppd not logging WinNT4.0
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords: Security
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-04 05:13 UTC by Yoda
Modified: 2007-04-18 16:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 09:37:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yoda 2001-08-04 05:13:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.19 i686)

Description of problem:
users are not looged when dialing in if they are WinNT4.0.  All other users
ate logged
both into wtmp and /etc/ppp/auth_up

Usually PAM is called but not with WINNT4.0



How reproducible:
Always

Steps to Reproduce:
1. Set up Server as dial in machine
2. Dial up with NT4.0
3. go "last -10"  NTUser not found.
2a. Dial in with win9x
3a.  go "last -10"  win9x User found
	

Actual Results:  wwh      ttyQ1b11     ppp22            Sat Aug  4 15:07 -
15:07  (00:00)
bmartin  ttyQ1b4      ppp21            Sat Aug  4 15:05   still logged in
jelliott ttyQ1a14     ppp19            Sat Aug  4 15:05   still logged in
calibra  ttyQ1b10     ppp16            Sat Aug  4 15:02   still logged in

Expected Results:  NTUser	ttyQ1ax	  pppxx              Sat Aug  4 15:07 
still logged in
wwh      ttyQ1b11     ppp22            Sat Aug  4 15:07 - 15:07  (00:00)
bmartin  ttyQ1b4      ppp21            Sat Aug  4 15:05   still logged in
jelliott ttyQ1a14     ppp19            Sat Aug  4 15:05   still logged in
calibra  ttyQ1b10     ppp16            Sat Aug  4 15:02   still logged in

Additional info:

This allows NTUsers to log in without any logging.  If this is chargable
then the user
is not registered

Comment 1 Yoda 2001-08-08 11:09:38 UTC
This happens if WinNT is set to accept only encrypted authentication

Comment 2 Kjartan Maraas 2003-03-31 20:35:23 UTC
Has this changed in later releases?

Comment 3 Mark J. Cox 2004-01-05 09:37:43 UTC
closing, no response


Note You need to log in before you can comment on or make changes to this bug.