Bug 508748 - Channel sharing 'protected' confirmation page gives no method of selection
Channel sharing 'protected' confirmation page gives no method of selection
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Red Hat Satellite QA List
:
Depends On:
Blocks: 471260 479998
  Show dependency treegraph
 
Reported: 2009-06-29 13:41 EDT by Clifford Perry
Modified: 2014-06-25 10:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-25 10:34:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Confirmation page, listing two orgs, but no way to select the protection on a per-org basis (199.32 KB, image/png)
2009-06-29 13:41 EDT, Clifford Perry
no flags Details

  None (edit)
Description Clifford Perry 2009-06-29 13:41:49 EDT
Created attachment 349829 [details]
Confirmation page, listing two orgs, but no way to select the protection on a per-org basis

Description of problem:
If you clone/create a custom channel - default is private for Org Sharing. If you choose :

This channel is protected and may only be accessed by specific trusted organizations. 

and hit the Update button you are refreshed to a screen (attached) which has orgs listed and then buttons. This page is a blanket make this action on all listed orgs. Since I wanted to be selective, I feel it would be better to have check boxes, allowing you to select which orgs you wish to grant access too. This may be that if you go from public to private we seem to use the same page/logic (which makes sense for an all or nothing change). 

Right now, the page is not as useful as it could be, since I cannot select specific orgs, have to go an edit it after this page for correct configuration of a protected sharing. 

Wonder if we can improve this page logic - otherwise, it just feels clunky to me. 



Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090625.0-i386-embedded-oracle.iso

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Note You need to log in before you can comment on or make changes to this bug.