Bug 508782 - iscsid/iscsistart segfault due to bad cast of conn_context data
iscsid/iscsistart segfault due to bad cast of conn_context data
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Mike Christie
Red Hat Kernel QE team
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 16:21 EDT by Mike Christie
Modified: 2010-10-23 06:27 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
the iscsi code contained a bad cast of a data structure. This would lead to a segmentation fault while logging in or out of an iSCSI target. With the logic now corrected, these segmentation faults do not occur.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:31:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Christie 2009-06-29 16:21:51 EDT
Description of problem:


iscsid/iscsistart will segault due to a bad cast of the conn context data struct to the data pointer. This patch
http://git.kernel.org/?p=linux/kernel/git/mnc/open-iscsi.git;a=commit;h=b176b84381ed92152f7d471d19642f1a3ac3f7f3
fixes the problem.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 10 Mike Christie 2009-07-09 13:07:48 EDT
Fixed in iscsi-initiator-utils-6.2.0.871-0.8.el5:
http://people.redhat.com/mchristi/iscsi/rhel5.4/iscsi-initiator-utils/
Comment 13 Evan McNabb 2009-07-13 15:36:49 EDT
Dell, can you please test this using the RPMs in comment #10?
Comment 14 Shyam kumar Iyer 2009-07-14 07:21:51 EDT
Yes the issue is fixed with the rpm in provided.
Comment 15 Evan McNabb 2009-07-14 09:25:50 EDT
Thank you for testing.
Comment 20 Ruediger Landmann 2009-08-26 08:01:58 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
the iscsi code contained a bad cast of a data structure. This would lead
to a segmentation fault while logging in or out of an iSCSI target. With
the logic now corrected, these segmentation faults do not occur.
Comment 21 errata-xmlrpc 2009-09-02 07:31:23 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1368.html

Note You need to log in before you can comment on or make changes to this bug.