Bug 508784 - Revert to previous behavior wrt unicode gettext and help messages
Revert to previous behavior wrt unicode gettext and help messages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
: Regression
: 509786 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 16:47 EDT by Cole Robinson
Modified: 2010-10-23 06:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:44:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Revert to 5.3 behavior. (6.09 KB, text/plain)
2009-06-29 16:51 EDT, Cole Robinson
no flags Details

  None (edit)
Description Cole Robinson 2009-06-29 16:47:43 EDT
We've had a length saga with the virt-* command line tools wrt to translations and unicode support.

First there was: https://bugzilla.redhat.com/show_bug.cgi?id=446950 . --help shows some garbage characters in translated unicode strings. A fix was provided, applied upstream, and added to RHEL.

Then came: https://bugzilla.redhat.com/show_bug.cgi?id=470176 . Turns out the previous patch fundamentally squashes error reporting in numerous places, so it was reverted for RHEL, _but_ kept upstream, since with newer python versions the issues in the second bug are not relevant.

With the virtinst rebase, the upstream code was brought in, so we need to revert the change originally associated with the first bug.

This is a regression from 5.3.

Example broken behavior (the 2 tracebacks shouldn't be there):

# LANG=ja_JP.UTF-8 virt-install --debug
月, 29  6月 2009 16:32:27 DEBUG    Requesting libvirt URI default
月, 29  6月 2009 16:32:27 DEBUG    Received libvirt URI 'xen:///'
Traceback (most recent call last):
  File "/usr/lib64/python2.4/logging/handlers.py", line 71, in emit
    if self.shouldRollover(record):
  File "/usr/lib64/python2.4/logging/handlers.py", line 149, in shouldRollover
    msg = "%s\n" % self.format(record)
  File "/usr/lib64/python2.4/logging/__init__.py", line 617, in format
    return fmt.format(record)
  File "/usr/lib64/python2.4/logging/__init__.py", line 408, in format
    s = self._fmt % record.__dict__
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 1: ordinal not in range(128)
Traceback (most recent call last):
  File "/usr/lib64/python2.4/logging/__init__.py", line 731, in emit
    msg = self.format(record)
  File "/usr/lib64/python2.4/logging/__init__.py", line 617, in format
    return fmt.format(record)
  File "/usr/lib64/python2.4/logging/__init__.py", line 408, in format
    s = self._fmt % record.__dict__
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 0: ordinal not in range(128)
月, 29  6月 2009 16:32:27 DEBUG    Received virt method 'xen'
月, 29  6月 2009 16:32:27 DEBUG    Hypervisor name is 'xen'
月, 29  6月 2009 16:32:27 ERROR    A name is required for the virtual machine. (use --prompt to run interactively)
Comment 1 Cole Robinson 2009-06-29 16:51:50 EDT
Created attachment 349872 [details]
Revert to 5.3 behavior.
Comment 5 Cole Robinson 2009-07-06 09:01:02 EDT
*** Bug 509786 has been marked as a duplicate of this bug. ***
Comment 6 Cole Robinson 2009-07-07 14:17:49 EDT
Built into python-virtinst-0.400.3-5.el5. Setting to MODIFIED.
Comment 9 Yan Tian 2009-07-23 22:39:25 EDT
Verified it was fixed in python-virtinst-0.400.3-5.el5.

# LANG=ja_JP.UTF-8 virt-install --debug
金, 24  7月 2009 10:40:09 DEBUG    Requesting libvirt URI default
金, 24  7月 2009 10:40:09 DEBUG    Received libvirt URI 'qemu:///system'
金, 24  7月 2009 10:40:09 DEBUG    Requesting virt method 'default'
金, 24  7月 2009 10:40:09 DEBUG    Received virt method 'hvm'
金, 24  7月 2009 10:40:09 DEBUG    Hypervisor name is 'qemu'
金, 24  7月 2009 10:40:09 ERROR    A name is required for the virtual machine. (use --prompt to run interactively)
Comment 11 errata-xmlrpc 2009-09-02 05:44:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1412.html

Note You need to log in before you can comment on or make changes to this bug.