Bug 508790 - KVM virt guest provisioning via webui fails, Failed to add tap interface 'vnet%d'
KVM virt guest provisioning via webui fails, Failed to add tap interface 'vne...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Mike McCune
Sayli Karmarkar
na
:
: 508791 (view as bug list)
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-06-29 17:14 EDT by wes hayutin
Modified: 2009-09-10 15:26 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:26:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-06-29 17:14:49 EDT
Description of problem:

6/26 rhel 5 server 

D: writeCachedLogin() invoked
D: Wrote pickled loginInfo at  1246305734.93  with expiration of  1246309334.93  seconds.
successfully retrieved authentication token from up2date server
D: logininfo: {'X-RHN-Server-Id': 1000012029, 'X-RHN-Auth-Server-Time': '1246309599.48', 'X-RHN-Auth': '34+g1zTy5cXGG0Vxyqg1jw==', 'X-RHN-Auth-Channels': [['rhel-x86_64-server-5', '20090624021247', '1', '1'], ['rhel-x86_64-server-vt-5', '20090624021247', '0', '1'], ['rhn-tools-rhel-x86_64-server-5', '20090627033137', '0', '1']], 'X-RHN-Auth-User-Id': '', 'X-RHN-Auth-Expire-Offset': '3600.0'}
D: handle_action {'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>kickstart_guest.initiate</methodName>\n<params>\n<param>\n<value><string>grandprix.rhndev.redhat.com</string></value>\n</param>\n<param>\n<value><string>test02-vmx.rhndev.redhat.com:1:kvmguest05</string></value>\n</param>\n<param>\n<value><string>qemu</string></value>\n</param>\n<param>\n<value><int>777</int></value>\n</param>\n<param>\n<value><string>kvmguest05</string></value>\n</param>\n<param>\n<value><int>512</int></value>\n</param>\n<param>\n<value><int>1</int></value>\n</param>\n<param>\n<value><int>3</int></value>\n</param>\n<param>\n<value><string>xenbr0</string></value>\n</param>\n<param>\n<value><string>/var/lib/xen/kvmguest05</string></value>\n</param>\n<param>\n<value><string> ksdevice=eth0 </string></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 4409}
D: handle_action actionid = 4409, version = 2
D: do_call kickstart_guest.initiate ('grandprix.rhndev.redhat.com', 'test02-vmx.rhndev.redhat.com:1:kvmguest05', 'qemu', 777, 'kvmguest05', 512, 1, 3, 'xenbr0', '/var/lib/xen/kvmguest05', ' ksdevice=eth0 ')
- looking for Cobbler at http://grandprix.rhndev.redhat.com/cobbler_api
- reading URL: http://grandprix.rhndev.redhat.com/cblr/svc/op/ks/system/test02-vmx.rhndev.redhat.com:1:kvmguest05
install_tree: http://grandprix.rhndev.redhat.com/ty/ISe0zy28
libvirtd (pid  4251) is running...
- using qemu hypervisor, type=kvm
libvir: QEMU error : Domain not found: no domain with matching name 'kvmguest05'
- adding disk: /var/lib/xen/kvmguest05 of size 3
libvir: QEMU error : Domain not found: no domain with matching uuid 'E�gk=�%5�3�> '
libvir: QEMU error : Domain not found: no domain with matching name 'kvmguest05'
libvir: QEMU error : internal error Failed to add tap interface 'vnet%d' to bridge 'xenbr0' : No such device
libvirt.libvirtError
internal error Failed to add tap interface 'vnet%d' to bridge 'xenbr0' : No such device
  File "/usr/share/rhn/spacewalkkoan/spacewalkkoan.py", line 129, in initiate_guest
    k.run()
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 296, in run
    self.virt()
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 584, in virt
    return self.net_install(after_download)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 503, in net_install
    after_download(self, profile_data)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 582, in after_download
    self.virt_net_install(profile_data)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 1051, in virt_net_install
    virt_type     =  self.virt_type
   File "/usr/lib/python2.4/site-packages/koan/qcreate.py", line 182, in start_install
    guest.start_install()
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 541, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 633, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
   File "/usr/lib64/python2.4/site-packages/libvirt.py", line 974, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)

D: Sending back response (1, 'Virtual kickstart failed. Koan error.', {'koan': 'internal error Failed to add tap interface \'vnet%d\' to bridge \'xenbr0\' : No such device   File "/usr/share/rhn/spacewalkkoan/spacewalkkoan.py", line 129, in initiate_guest\n    k.run()\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 296, in run\n    self.virt()\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 584, in virt\n    return self.net_install(after_download)\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 503, in net_install\n    after_download(self, profile_data)\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 582, in after_download\n    self.virt_net_install(profile_data)\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 1051, in virt_net_install\n    virt_type     =  self.virt_type\n   File "/usr/lib/python2.4/site-packages/koan/qcreate.py", line 182, in start_install\n    guest.start_install()\n   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 541, in start_install\n    return self._do_install(consolecb, meter, removeOld, wait)\n   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 633, in _do_install\n    self.domain = self.conn.createLinux(install_xml, 0)\n   File "/usr/lib64/python2.4/site-packages/libvirt.py", line 974, in createLinux\n    if ret is None:raise libvirtError(\'virDomainCreateLinux() failed\', conn=self)\n'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))
Comment 1 wes hayutin 2009-06-29 17:15:45 EDT
tried on my own server and on test02-vmx
Comment 2 wes hayutin 2009-06-29 18:02:11 EDT
Prad, and I worked around the issue by setting the bridge interface correctly.
This bug should track programmaticly  setting the proper bridge for kvm guests... in this case vrb0
Comment 3 Mike McCune 2009-06-30 13:25:44 EDT
working on this now
Comment 4 Mike McCune 2009-06-30 14:57:08 EDT
if you select KVM you now get virbr0 as your default bridge
Comment 5 Mike McCune 2009-06-30 15:19:47 EDT
*** Bug 508791 has been marked as a duplicate of this bug. ***
Comment 6 Mike McCune 2009-06-30 15:22:40 EDT
Also need to fix the /var/lib/xen path
Comment 7 Mike McCune 2009-06-30 19:39:29 EDT
We now default and use /var/lib/libvirt/images as our default path.
Comment 8 Mike McCune 2009-07-03 01:26:35 EDT
ON_QA
Comment 9 Sayli Karmarkar 2009-07-06 11:37:44 EDT
verified. 
When I create a kvm guest kickstart profile default bridge is virbr0 and guest is created in /var/lib/libvirt/images/ directory.

rhn_check log:

...

install_tree: http://rlx-2-08.rhndev.redhat.com/ty/NVlaijqX
libvirtd (pid  26239) is running...
- using qemu hypervisor, type=kvm
libvir: QEMU error : Domain not found: no domain with matching name 'foobar3'
- adding disk: /var/lib/libvirt/images/foobar3 of size 3

....
Comment 10 Brandon Perkins 2009-07-29 16:40:39 EDT
Release Pending.  Multiple versions of this has been done today.
Comment 11 Brandon Perkins 2009-09-10 15:26:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.