This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 508794 - Renumbers ethernet interfaces from Fedora 10
Renumbers ethernet interfaces from Fedora 10
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 509333 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 17:46 EDT by Bob Gustafson
Modified: 2009-10-27 04:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 04:16:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2009-06-29 17:46:09 EDT
Description of problem:

I was having a lot of difficulty in configuring a connection during Anaconda install and after successful boot into Fedora 11. Never got a connection during this period.

I have two single board ethernet interfaces and one quad board.

To reduce complexity, I had only two cables plugged in. While it was still Fedora 10, I copied off some files through my main LAN connection.

After awhile of trial and error network configuration (disabling NetworkManager in the process), I discovered that my eth0, eth1, eth2, eth3, eth4, eth5 were coming out of ports different from what they had been under Fedora 10.

After this nugget of information, I was able to proceed and do a successful network configuration.

Version-Release number of selected component (if applicable):

  # NetworkManager --help gives no version number

How reproducible:

  Tough to go back to Fedora 10 at this point

Steps to Reproduce:
1. Start with Fedora 10 on a system with lots of ethernet ports
2. Write down the phys port -> ethN table
3. Install Fedora 11
4. Write down new phys port -> ethN table
  
Actual results:

 Tables in step 2 and 4 above, are different

Expected results:

 Tables in step 2 and 4 above, are the same

Additional info:
Comment 1 Niels Haase 2009-07-06 04:36:27 EDT
*** Bug 509333 has been marked as a duplicate of this bug. ***
Comment 2 Dan Williams 2009-10-26 18:09:04 EDT
Persistent MAC -> ifname mappings are created and maintained by udev; it may be that Fedora started doing this only in F-11.
Comment 3 Harald Hoyer 2009-10-27 04:16:58 EDT
check and configure /etc/udev/rules.d/70-persistent-net.rules

Note You need to log in before you can comment on or make changes to this bug.