Bug 508810 - pa is failing to load
pa is failing to load
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 20:59 EDT by Paul F. Johnson
Modified: 2009-06-30 16:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 16:37:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2009-06-29 20:59:45 EDT
Description of problem:
Pulseaudio is currently failing to initialise either module-hal-detect or module-detect

Version-Release number of selected component (if applicable):
0.9.16-1.test1

How reproducible:
Always

  
Actual results:
Output from pulseaudio -vvvvv

I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: core-rtclock.c: Timer slack is set to 50 us.
D: core-util.c: RealtimeKit worked.
I: core-util.c: Successfully gained nice level -11.
I: main.c: This is PulseAudio 0.9.16-test1
D: main.c: Compilation host: i386-redhat-linux-gnu
D: main.c: Compilation CFLAGS: -ggdb -Wall -W -Wextra -pipe -Wno-long-long -Winline -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing=2 -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: main.c: Running on host: Linux i686 2.6.31-0.33.rc1.git2.fc12.i686.PAE #1 SMP Fri Jun 26 22:40:04 EDT 2009
D: main.c: Found 2 CPUs.
I: main.c: Page size is 4096 bytes
D: main.c: Compiled with Valgrind support: no
D: main.c: Running in valgrind mode: no
D: main.c: Optimized build: no
D: main.c: All asserts enabled.
I: main.c: Machine ID is 07e6d708ad271922461a5fe449d44a3e.
I: main.c: Session ID is 07e6d708ad271922461a5fe449d44a3e-1246322826.967699-1700782610.
I: main.c: Using runtime directory /home/paul/.pulse/07e6d708ad271922461a5fe449d44a3e:runtime.
I: main.c: Using state directory /home/paul/.pulse.
I: main.c: Running in system mode: no
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: memblock.c: Using shared memory pool with 1024 slots of size 64.0 KiB each, total size is 64.0 MiB, maximum usable slot size is 65496
D: database-tdb.c: Opened TDB database '/home/paul/.pulse/07e6d708ad271922461a5fe449d44a3e:device-volumes.tdb'
I: module-device-restore.c: Sucessfully opened database file '/home/paul/.pulse/07e6d708ad271922461a5fe449d44a3e:device-volumes'.
I: module.c: Loaded "module-device-restore" (index: #0; argument: "").
D: database-tdb.c: Opened TDB database '/home/paul/.pulse/07e6d708ad271922461a5fe449d44a3e:stream-volumes.tdb'
I: module-stream-restore.c: Sucessfully opened database file '/home/paul/.pulse/07e6d708ad271922461a5fe449d44a3e:stream-volumes'.
I: module.c: Loaded "module-stream-restore" (index: #1; argument: "").
D: database-tdb.c: Opened TDB database '/home/paul/.pulse/07e6d708ad271922461a5fe449d44a3e:card-database.tdb'
I: module-card-restore.c: Sucessfully opened database file '/home/paul/.pulse/07e6d708ad271922461a5fe449d44a3e:card-database'.
I: module.c: Loaded "module-card-restore" (index: #2; argument: "").
I: module.c: Loaded "module-augment-properties" (index: #3; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9.16/modules/module-hal-detect.so': failure
E: module.c: Failed to open module "module-detect": file not found
E: main.c: Module load failed.
E: main.c: Failed to initialize daemon.
I: module.c: Unloading "module-device-restore" (index: #0).
I: module.c: Unloaded "module-device-restore" (index: #0).
D: core-subscribe.c: Dropped redundant event due to remove event.
I: module.c: Unloading "module-stream-restore" (index: #1).
I: module.c: Unloaded "module-stream-restore" (index: #1).
D: core-subscribe.c: Dropped redundant event due to remove event.
I: module.c: Unloading "module-card-restore" (index: #2).
I: module.c: Unloaded "module-card-restore" (index: #2).
D: core-subscribe.c: Dropped redundant event due to remove event.
I: module.c: Unloading "module-augment-properties" (index: #3).
I: module.c: Unloaded "module-augment-properties" (index: #3).
D: core-subscribe.c: Dropped redundant event due to remove event.
I: main.c: Daemon terminated.


Expected results:
Either of these modules should load and sound returns to my machine

Additional info:
I get the same results if I chown paul:audio /dev/snd -R
Last update to rawhide, 29th June 2009

[paul@PB3 pulse]# uname -r
2.6.31-0.33.rc1.git2.fc12.i686.PAE
Comment 1 Lennart Poettering 2009-06-30 16:37:28 EDT
In Rawhide module-hal-detect got replaced by module-udev-detect, please make sure to update your default.pa accordingly if you modified it.

Note You need to log in before you can comment on or make changes to this bug.