Bug 508812 - corruption of display (Radeon graphics card) unless "nomodeset" is used as kernel parameter
corruption of display (Radeon graphics card) unless "nomodeset" is used as ke...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 21:36 EDT by Need Real Name
Modified: 2009-07-26 00:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: F11 as of 2009-06-30
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-05 14:20:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2009-06-29 21:36:09 EDT
Description of problem:  Corruption of display with fc 11 on intel graphics (ATI Radeon Mobility M7 LW [Radeon Mobility 7500].


Version-Release number of selected component (if applicable):  don't know


How reproducible: start x without kernel parameter "nomodeset"


Steps to Reproduce:
1.see above
2.
3.
  
Actual results:  corrupted display: blurry, fuzzy, text hard to read. etc.


Expected results: sharp display


Additional info: I'm sorry I can't give any more information on this.  I'm filing this admittedly less-than-useful description because the "common f11 bugs" web page said this was important since "in future kernel mode setting will be the only available method, and so we wish to ensure all problems caused by kernel mode setting are fixed."

Therefore, if it will be useful, please contact me with requests for more detailed information.

Thanks.
Comment 1 Need Real Name 2009-06-29 21:45:12 EDT
Please ignore the mention of "intel" - obviously, it's an ATI graphics card.
Comment 2 Matěj Cepl 2009-06-30 09:09:02 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

And there is always possibility that this is a duplicate of bug 498457

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Need Real Name 2009-06-30 22:50:30 EDT
Strangely, I can no longer reproduce this behavior: I've rebooted now a couple of times without using "nomodeset," and the display looks fine.

Before I cancel this bug, I should mention that the problem was severe before.  During and after installation the display was extremely bad, essentially impossible to use unless I applied "nomodeset."  So it's very mysterious to me why it's o.k. now.

New behavior, now that I've removed "nomodeset" from grub.conf: occasional poweroff of the display at odd, unpredictable times, but it turns back on upon keyboard activity. (Much like bug 501601).
Comment 4 Matěj Cepl 2009-07-06 03:15:54 EDT
OK, I am not sure what to do about this bug. Let's close it, because the description originally described here is gone, and let's join the party at bug 501601 (you can add yourself to the CC list of the bug). If the behaviour described here shows again, please, reopen this bug with additional information (especially with everything I have asked you for in the comment 2). And if the bug 501601 turns out to be Xorg (and/or hardware specific), we will deal with it in the other bug.

Thanks for reporting the issue in the first place.
Comment 5 Mike Ball 2009-07-26 00:40:15 EDT
Boy am I glad I stumbled across this bug report.  

I have a Dell latitude C640 laptop with the same video: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500].  I installed fedora 11 x386 3 days ago.  All worked perfectly, except the LCD screen was fuzzy and hardly readable - almost like the system was set up for a 32 bit palette size but running on a 16 bit palette size system with missing colors, or every other vertical column of pixels were shifted 2 columns to the right, or maybe missing - hard to explain.

I found no hints through google or fedoraforum.org.  I didn't really know how to describe the problem.  I could do a print screen and email the image to another computer, and it looked fine.  I could VNC into the laptop from another computer and all looked fine (remote shell looked fine on the other computer). I loaded sysgtem-config-display, but could not find any settings that would help. I edited /etc/X11/xorg.conf and changed: Section "Device", Driver from "radeon" to "vesa", and could get a beautiful display up to 800x600.

I saw this bug post, and put "nomodeset" in grub.conf, and now the screen is beautiful.  I can run max 1024x768, millions of colors, and now I have a great web surfer running fedora 11.  All works perfectly.

Note You need to log in before you can comment on or make changes to this bug.