Bug 508821 - evince uses 100% cpu in the middle of some pdf documents, and stops displaying them
evince uses 100% cpu in the middle of some pdf documents, and stops displayin...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 01:16 EDT by Bob Hill
Modified: 2013-04-02 00:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-15 14:20:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the document "investigation.pdf" referred to in the bug description. (1.58 MB, application/pdf)
2009-06-30 01:20 EDT, Bob Hill
no flags Details
This is the document "immobilien.pdf" referred to in the bug description. (2.41 MB, application/pdf)
2009-06-30 01:24 EDT, Bob Hill
no flags Details

  None (edit)
Description Bob Hill 2009-06-30 01:16:27 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4

This bug concerns  evince-2.26.2-1.fc11.i586  on Fedora 11.

Occasionally, in the middle of displaying a pdf document, evince starts using 100% cpu, and stops displaying any further pages from the document.
The bug can be reproduced by viewing either of the two attached pdf documents:

a. investigation.pdf  "An investigation of inverted yield curves and economic downturns":  evince displays the first 12 of the 224 pages in this document ok, but attempting to display page 13 results in 100% CPU, and page 13 is not displayed ("Loading").

b. immobilien.pdf  "Der Immobilien Brief":  evince displays the first 12 of the 35 pages in this document ok, but attempting to display page 13 results in 100% CPU, and page 13 is not displayed ("Loading").

Both these documents can be displayed fine with Adobe Reader 9.1.1 under Win-XP.

Reproducible: Always

Steps to Reproduce:
1. Display either of the attached pdf documents with evince.
2. Scroll down to page 12  -  no problem so far.
3. Attempt to scroll further down to page 13.
Actual Results:  
evince displays "Loading"  (instead of the actual contents of page 13)  and uses 100% cpu.  The evince process must be killed to free up the cpu.

Expected Results:  
evince should display the actual contents of page 13, and not consume 100% cpu.

Please note that the problem occurring on page 13 of both attached pdf documents is surely a simple coincidence.  The two documents have entirely different content, but just coincidentally both contain graphics or whatever in their respective 13th pages which provoke this bug.

This bug would appear to be similar  (but not identical)  to bugs 163935 and 183397, both of which concern very much older Fedora releases.
Comment 1 Bob Hill 2009-06-30 01:20:35 EDT
Created attachment 349904 [details]
This is the document  "investigation.pdf"  referred to in the bug description.
Comment 2 Bob Hill 2009-06-30 01:24:23 EDT
Created attachment 349905 [details]
This is the document  "immobilien.pdf"  referred to in the bug description.
Comment 4 Bert DeKnuydt 2009-11-09 07:25:15 EST
Both documents render for me, but they do take an 'abnormally' long time om the pages mentioned.
Comment 5 Bob Hill 2010-04-15 14:20:33 EDT
Closing due to lack of response.

Note You need to log in before you can comment on or make changes to this bug.