Bug 508851 - service network start doesn't rise up br0:1 interface
service network start doesn't rise up br0:1 interface
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
10
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 516998
  Show dependency treegraph
 
Reported: 2009-06-30 05:02 EDT by Veli-Pekka Kestilä
Modified: 2014-03-16 23:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 18:14:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Veli-Pekka Kestilä 2009-06-30 05:02:17 EDT
Description of problem:

When starting network with alias on bridge system doesn't rise alias interface up.
ifup br0:1 works without a problem.


Version-Release number of selected component (if applicable):


How reproducible:

create bridge with:
ifcfg-br0 in network-sripts
create ip alias
ifcfg-br0:1 in network-scripts

restart network and br0:1 doesn't rise up.
use ifup br0:1 and interface rises up without a problem.

Actual results:

br0:1 doesn't rise up. And isn't in the ifconfig -a listing

Expected results:

br0:1 rises up and is in ifconfig -a listing
Comment 1 Bill Nottingham 2009-09-02 15:56:28 EDT
I've just tried this on rawhide, and it works for me.

ifcfg-eth0:
# Intel Corporation 82545EM Gigabit Ethernet Controller (Copper)
DEVICE=eth0
HWADDR=00:D0:B7:C2:CE:80
ONBOOT=yes
TYPE=Ethernet
BRIDGE=br0

ifcfg-br0:
DEVICE=br0
BOOTPROTO=dhcp
ONBOOT=yes
TYPE=Bridge

ifcfg-br0:0:
# Intel Corporation 82545EM Gigabit Ethernet Controller (Copper)
DEVICE=br0:0
BOOTPROTO=static
ONBOOT=yes
IPADDR=192.168.1.1
NETMASK=255.255.255.0

What does your configuration look like?
Comment 2 Veli-Pekka Kestilä 2009-09-02 18:14:36 EDT
Seems that I was missing 

ONBOOT=yes

line from the ifconfig-br0:0 and originally had ifconfig-br0:1, but that probably didn't matter as much and because of that missing line it didn't come up. Should have investigated it more before filing the bug-report. Sorry to bother you with it. 

I will close the bug.

Note You need to log in before you can comment on or make changes to this bug.