This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 508859 - Links to documentation on first page of RHN Proxy 5.2 installation broken
Links to documentation on first page of RHN Proxy 5.2 installation broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
520
All Linux
medium Severity low
: ---
: ---
Assigned To: Shannon Hughes
Milan Zazrivec
:
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-06-30 05:44 EDT by Jan Pazdziora
Modified: 2009-09-10 10:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:39:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-06-30 05:44:24 EDT
Description of problem:

I have Satellite 5.3.0, I have RHEL 5 system registered to it, and I try to activate that system as RHN Proxy. On the first page, there are links to documentation and those documentation pages say Page Not Found.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090625.0-i386-embedded-oracle
RHN Proxy v5.2

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have Satellite 5.3.0, have RHN Proxy v5.2 and v5.3 channels synced.
2. Register RHEL 5 system, give it provisioning entitlements.
3. Click on Details > Proxy.
4. Select RHN Proxy v5.2, click Activate Proxy.
5. The page will say

 Welcome to the Satellite Proxy version 5.3 installer.

Please review the RHN Proxy Installation Guide for more details regarding this installation process.

This system does not meet the following requirements:

    * The system must support the configfiles.deploy capability
    * The system must support the script.run capability

You must satisfy all the requirements before installing Satellite Proxy 5.3. See the Satellite Proxy Documentation for more details 

The RHN Proxy Installation Guide and Satellite Proxy Documentation are links to https://satellite/rhn/help/proxy/rhn520/en-US/ap-guiinstall.jsp, resp. https://satellite/rhn/help/proxy/rhn520/en-US/ch-requirements.jsp#s1-software-requirements
  
Actual results:

Those pages say:

Page Not Found

The page you requested, /rhn/help/proxy/rhn520/en-US/ap-guiinstall.jsp, was not found.

and

Page Not Found

The page you requested, /rhn/help/proxy/rhn520/en-US/ch-requirements.jsp, was not found.

Expected results:

Either pages on those URLs existing, or the links on that Proxy installation page pointing to some other existing documentation pages.

Additional info:
Comment 1 Clifford Perry 2009-06-30 12:18:05 EDT
Shannon - can you look to update the doc link. 

Cliff
Comment 2 Shannon Hughes 2009-07-01 14:00:22 EDT
fixed the first link. removed the 2nd link...going to review approach in 540 due to doc dir structuring changes and future i18n goals. imho, the 2nd link is not needed though.
Comment 3 Shannon Hughes 2009-07-06 11:16:37 EDT
mass move to onqa
Comment 4 Miroslav Suchý 2009-07-07 03:34:54 EDT
For record - commit 8902f2c7b650b66763fc894da26497d3b4fd2652
Comment 5 Milan Zazrivec 2009-07-09 08:02:54 EDT
Verified, spacewalk-web-0.5.23-22
Comment 6 John Matthews 2009-08-07 13:20:41 EDT
Move to RELEASE_PENDING
Stage ISO 7/24

Verified the link is valid
https://rhndev1.z900.redhat.com/rhn/help/proxy/rhn530/en-US/s1-installation-
install-config.jsp
Comment 7 Brandon Perkins 2009-09-10 10:39:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.