Bug 508863 - ekiga crashes in gmdialog if video format is not supported
ekiga crashes in gmdialog if video format is not supported
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ekiga (Show other bugs)
5.3
All Linux
urgent Severity high
: rc
: ---
Assigned To: Benjamin Otte
Desktop QE
: Patch, ZStream
Depends On:
Blocks: 502912 807971 661502
  Show dependency treegraph
 
Reported: 2009-06-30 06:17 EDT by Olivier Fourdan
Modified: 2013-09-23 07:17 EDT (History)
14 users (show)

See Also:
Fixed In Version: ekiga-2.0.2-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 07:17:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First crash due to vastart misplaced (10.47 KB, text/plain)
2009-06-30 06:17 EDT, Olivier Fourdan
no flags Details
Second crash due to vsnprintf (17.25 KB, text/plain)
2009-06-30 06:17 EDT, Olivier Fourdan
no flags Details
Proposed patch from upstream (1.13 KB, patch)
2009-06-30 06:19 EDT, Olivier Fourdan
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 421801 None None None Never

  None (edit)
Description Olivier Fourdan 2009-06-30 06:17:05 EDT
Created attachment 349934 [details]
First crash due to vastart misplaced

Description of problem:

There are a couple of bugs in gmdialog that cause ekiga to crash when an error is to be displayed.

Version-Release number of selected component (if applicable):

ekiga-2.0.2-7.0.2

How reproducible:

100% reproducible

Steps to Reproduce:
1. Plug an UVC webcam 
2. Run ekiga setup druid
  
Actual results:

Ekiga crashes with attached backtraces.

Expected results:

No crash, the dialog shows

Additional info:

I believe this is is upstream bug 421801 (http://bugzilla.gnome.org/show_bug.cgi?id=421801)

The patches from upstream fix the issue in my reproducer.
Comment 1 Olivier Fourdan 2009-06-30 06:17:36 EDT
Created attachment 349935 [details]
Second crash due to vsnprintf
Comment 2 Olivier Fourdan 2009-06-30 06:19:01 EDT
Created attachment 349936 [details]
Proposed patch from upstream

Fixes both crash cases.
Comment 5 Charlie Wyse 2009-07-24 13:32:37 EDT
Is this patch gonna make it into RHEL5.4?
Comment 7 RHEL Product and Program Management 2009-11-06 14:09:23 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 10 RHEL Product and Program Management 2010-08-09 15:18:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 17 Benjamin Otte 2010-12-08 17:17:17 EST
Built ekiga-2.0.2-10 with the patch applied.

Note You need to log in before you can comment on or make changes to this bug.