Bug 508885 - unable to use kickstart advanced options and select a proxy for the same kickstart
unable to use kickstart advanced options and select a proxy for the same kick...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Partha Aji
wes hayutin
https://grandprix.rhndev.redhat.com/r...
: Regression
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-06-30 08:22 EDT by wes hayutin
Modified: 2009-09-10 15:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:26:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-06-30 08:22:34 EDT
Description of problem:

unable to use kickstart advanced options and select a proxy for the same kickstart

virt and regular kickstarts

https://grandprix.rhndev.redhat.com/rhn/systems/details/kickstart/ScheduleWizard.do

https://grandprix.rhndev.redhat.com/rhn/systems/details/virtualization/ProvisionVirtualizationWizard.do

recreate:
Start to schedule a kickstart
select a proxy to be used
also click advanced options to change some of the ks values on the fly...

cant be done :)

Partha sounds like his is Johnny on the spot and has a fix :)
Comment 1 Clifford Perry 2009-06-30 12:27:13 EDT
Sounds like a regression to me. We have previously, in 5.x major release cycles (pretty sure 5.1.x) fixed this code area, where if you flipped between advanced options and schedule page for kickstart lose information selected on the other page. 

Need to fix.
Comment 2 Partha Aji 2009-06-30 12:34:48 EDT
Should be fixed in the next iso 
http://git.fedorahosted.org/git/?p=spacewalk.git;a=commit;h=b5aa175bcaae5abca0f60bbdfa46fac2b053d02e

Steps
1) Goto guest provuisioning or regular provisioning page
2) Select a proxy
3) Goto Advanced configuration and come back to the main page by clicking Basic options
The Proxy value should get remembered.

Similarly select some of the options like kernelParams and postKernelParams, in advanced options page and click basic options, then return back to advanced options. 
The values you selected/entered in advanced options  must be retained.
Comment 3 Partha Aji 2009-07-06 13:30:58 EDT
Moving to ON_QA
Comment 4 wes hayutin 2009-07-07 14:06:02 EDT
looks like the session info is saved now..
looks good..

verified.
Comment 5 Brad Buckingham 2009-08-06 14:38:01 EDT
verified w/ 7/24 stage iso... moving to RELEASE_PENDING

verified that session information is saved when going between the basic and advanced configuration options when scheduling a ks
Comment 6 Brandon Perkins 2009-09-10 15:26:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.