Bug 508923 - sr#1841218/ Xvfb segfaults on fbBlt/memcpy
sr#1841218/ Xvfb segfaults on fbBlt/memcpy
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: OtherQA, Patch, Triaged
Depends On: 467370
Blocks: 502912 590060 743405 807972
  Show dependency treegraph
 
Reported: 2009-06-30 10:48 EDT by Adam Jackson
Modified: 2013-01-08 02:39 EST (History)
9 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.1.1-48.93.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 467370
Environment:
Last Closed: 2013-01-08 02:39:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Adam Jackson 2009-06-30 10:49:53 EDT
Original bug was in the PutImage path.  This new crash is in the software Mesa path.
Comment 10 RHEL Product and Program Management 2010-09-29 12:48:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 14 RHEL Product and Program Management 2011-05-31 11:36:56 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 21 Adam Jackson 2012-07-03 12:25:10 EDT
This is a long shot, but this bug is ringing some faint bells.  The initial report says the bug occurs when Xvfb is launched like this:

# /usr/bin/Xvfb :3 -screen 3 1280x1024x24 -fbdir /var/tmp

Two questions:

1) Does it work if you change the -screen argument to "-screen 3 1280x1024x24+32" ?

2) Does it work if you append "-extension COMPOSITE" to the command line?
Comment 26 errata-xmlrpc 2013-01-08 02:39:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0083.html

Note You need to log in before you can comment on or make changes to this bug.