Bug 508957 - pdftoppm missing from poppler-utils [NEEDINFO]
pdftoppm missing from poppler-utils
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: poppler (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Denise Dumas
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 12:22 EDT by Eirik
Modified: 2014-06-02 09:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:19:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (erobertstad)


Attachments (Terms of Use)

  None (edit)
Description Eirik 2009-06-30 12:22:57 EDT
poppler/poppler-utils replaced xpdf in el5, however pdftoppm isn't being distributed with poppler-utils:

el4 xpdf:
/usr/bin/pdftoppm <--- 
/usr/bin/pdftops
/usr/bin/pdftotext
/usr/share/man/man1/pdftoppm.1.gz
/usr/share/man/man1/pdftops.1.gz
/usr/share/man/man1/pdftotext.1.gz

el5 poppler-utils:
NOKEY, key ID 37017186
/usr/bin/pdffonts
/usr/bin/pdfimages
/usr/bin/pdfinfo
/usr/bin/pdftohtml
/usr/bin/pdftops
/usr/bin/pdftotext
/usr/share/man/man1/pdffonts.1.gz
/usr/share/man/man1/pdfimages.1.gz
/usr/share/man/man1/pdfinfo.1.gz
/usr/share/man/man1/pdftohtml.1.gz
/usr/share/man/man1/pdftops.1.gz
/usr/share/man/man1/pdftotext.1.gz
Comment 2 Ingvar Hagelund 2011-01-14 06:16:28 EST
Rebuilding poppler-utils with pdftoppm requires --disable-splash-output, which is non-compatible with fontconfig, if I have understood this correctly. I tried to do this, but ended up with lots of font related errors from pdftoppm. 

So with the version of poppler in rhel5, this is not doable without a bit heavier patching.

The easiest workaround is probably to grab the epel xpdf package, and readd pdftoppm there, like this, see attached patch.

Ingvar
Comment 3 Ingvar Hagelund 2011-01-14 06:18:04 EST
attaching a patch for xpdf in a poppler bug seems a bit strange, so I just put it here: http://users.linpro.no/ingvar/xpdf.spec.pdftoppm.patch

Best regards,
Ingvar
Comment 6 RHEL Product and Program Management 2014-03-07 07:49:44 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-02 09:19:28 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.