Bug 508996 - mwm's icon box has graphics corruption
mwm's icon box has graphics corruption
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openmotif (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Thomas Woerner
BaseOS QE
: Patch
Depends On:
Blocks: 590060
  Show dependency treegraph
 
Reported: 2009-06-30 15:07 EDT by Jeff Bastian
Modified: 2013-04-12 16:19 EDT (History)
4 users (show)

See Also:
Fixed In Version: openmotif-2.3.1-4.el5
Doc Type: Bug Fix
Doc Text:
Previously, when the icon box in MWM was enabled, placing a window over the icon box and removing the window afterwards caused a graphics corruption of the icons. With this update, icons in the icon box are no longer corrupt.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-01 08:33:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of mwm icon box (1.70 KB, image/png)
2009-06-30 15:14 EDT, Jeff Bastian
no flags Details
upstream patch (533 bytes, patch)
2009-12-30 18:51 EST, Jeff Bastian
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
MotifZone 1495 None None None Never

  None (edit)
Description Jeff Bastian 2009-06-30 15:07:10 EDT
Description of problem:
If mwm's icon box is enabled, the icons have a gray box overlaid on the lower-right corner of each icon.

Version-Release number of selected component (if applicable):
openmotif-2.3.1-2.el5

How reproducible:
every time

Steps to Reproduce:
1. Edit (or create) ~/.vnc/xstartup and set contents to
#!/bin/sh
unset SESSION_MANAGER
exec /usr/bin/mwm -xrm 'Mwm*useIconBox:true'

2. vncserver

3. vncviewer :1

4. right-click on root window and choose "New Window" to open an xterm

5. drag the xterm over the icon box and then off again, and the icon will
   partially obscured in the lower-right corner with a gray box


Actual results:
icons in icon box are corrupt

Expected results:
no corruption

Additional info:
does not appear to be reported upstream at http://bugs.openmotif.org/
Comment 1 Jeff Bastian 2009-06-30 15:14:13 EDT
Created attachment 350010 [details]
screenshot of mwm icon box
Comment 2 J.H.M. Dassen (Ray) 2009-08-12 05:58:27 EDT
This issue is reproducible with upstream CVS HEAD. Please report it upstream.
Comment 3 Jeff Bastian 2009-08-12 14:26:56 EDT
Upstream bug report at http://bugs.openmotif.org/show_bug.cgi?id=1495
Comment 5 RHEL Product and Program Management 2009-11-06 14:10:27 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 Jeff Bastian 2009-12-30 18:51:35 EST
Created attachment 381026 [details]
upstream patch

The upstream bug has been resolved; attached is the patch that fixes the problem on RHEL 5.4.
Comment 9 Issue Tracker 2010-01-08 12:06:21 EST
Event posted on 2010-01-08 18:06 CET by rdassen

Test packages for RHEL 5.4 with the patch from comment 6 have been tested
successfully by the end user on whose behalf this issue was reported to
Red Hat.

Internal Status set to 'Waiting on Engineering'

This event sent from IssueTracker by rdassen 
 issue 312335
Comment 12 RHEL Product and Program Management 2010-08-09 14:32:27 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 15 Thomas Woerner 2010-08-18 10:37:06 EDT
Fixed in openmotif-2.3.1-4.el5

Here is the build: https://brewweb.devel.redhat.com/buildinfo?buildID=141000
Comment 18 Martin Prpič 2010-08-25 02:49:46 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, when the icon box in MWM was enabled, placing a window over the icon box and removing the window afterwards caused a graphics corruption of the icons. With this update, icons in the icon box are no longer corrupt.
Comment 20 errata-xmlrpc 2010-09-01 08:33:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0667.html

Note You need to log in before you can comment on or make changes to this bug.