Bug 509006 - denied execmod for gpg inside EL4 mock
denied execmod for gpg inside EL4 mock
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 16:21 EDT by Orion Poplawski
Modified: 2009-08-25 17:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-25 17:13:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-06-30 16:21:11 EDT
Description of problem:

gpg fails to run inside a EL4 mock chroot (building a kernel) with:

type=1400 audit(1246392854.984:4): avc:  denied  { execmod } for  pid=31749 comm="gpg" path="/usr/bin/gpg" dev=xvda1 ino=667610 scontext=unconfined_u:system_r:unconfined_notrans_t:s0 tcontext=system_u:object_r:gpg_exec_t:s0 tclass=file

Not sure if mock/selinux really play nice together, but this is my first real failure in a long time.

Version-Release number of selected component (if applicable):
selinux-policy-3.5.13-58.fc10.noarch
Comment 1 Daniel Walsh 2009-08-21 17:38:29 EDT
No idea what caused this, have you seen it again?
Comment 2 Orion Poplawski 2009-08-25 17:13:02 EDT
I've since moved my mock builder to F11 and cannot reproduce.

Note You need to log in before you can comment on or make changes to this bug.