Bug 509033 - No option to configure network
No option to configure network
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 19:01 EDT by Tethys
Modified: 2009-07-29 09:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 21:47:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2009-06-30 19:01:09 EDT
Description of problem:
Installing F11 leaves no network configured

Version-Release number of selected component (if applicable):
Whatever comes with the F11 install DVD

How reproducible:
Every time

Steps to Reproduce:
1. Install F11
2. Realise it didn't ask about your network
3. Don't have a working network
  
Actual results:
No network

Expected results:
Anaconda to ask for details about the IP address, gateway, etc
I want to use

Additional info:
Maybe it would work if I had DHCP on my network. But I don't...
Comment 1 David Cantrell 2009-07-01 00:28:06 EDT
This was a planned feature from back at Fedora 10:

    https://fedoraproject.org/wiki/Anaconda/Features

Specifically:

    https://fedoraproject.org/wiki/Anaconda/Features/NetConfigForNM
Comment 2 Tethys 2009-07-01 18:54:22 EDT
Very definitely a bug. From the NetConfigForNM wiki page:

> Users should not notice a significant different with the way
> network configuration works during installation. Most of the
> changes are on the backend. Users will still be required to
> pick an interface to use and to fill in any required information
> such as WPA keys or static settings.

I wasn't given the option to enter any static network settings.
That meant that my network didn't work, so no NIS or NFS and I
was unable to log in, nor any way of entering the details, short
of logging in as root on a console and editing the appropriate
files under /etc/sysconfig. I thought you were trying to move
away from that...
Comment 3 David Cantrell 2009-07-27 17:35:57 EDT
(In reply to comment #2)
> Very definitely a bug. From the NetConfigForNM wiki page:
> 
> > Users should not notice a significant different with the way
> > network configuration works during installation. Most of the
> > changes are on the backend. Users will still be required to
> > pick an interface to use and to fill in any required information
> > such as WPA keys or static settings.
> 
> I wasn't given the option to enter any static network settings.
> That meant that my network didn't work, so no NIS or NFS and I
> was unable to log in, nor any way of entering the details, short
> of logging in as root on a console and editing the appropriate
> files under /etc/sysconfig. I thought you were trying to move
> away from that...  

Rather than having this happen during installation, it happens on the installed system using the NetworkManager applet.  Right click the NetworkManager icon on the GNOME menu bar and select Edit Connections.  From there you can set up all of your interfaces.

If you don't want to do this, you can still create ifcfg-ethX files in /etc/sysconfig/network-scripts and use the old 'network' service, however the installer no longer gives you a screen to set these up.  If you want to configure them during installation, you will need to perform a kickstart installation.
Comment 4 Tethys 2009-07-27 18:34:50 EDT
From http://fedoraproject.org/wiki/Objectives:

> Create a complete, general-purpose operating system

I'm sorry, but an OS that doesn't let you configure the network on
install, and only lets you configure it afterwards should you happen
to be running a GNOME desktop (which I'm not) is in no way general
purpose.

And quite apart from that, even if I was running a GNOME desktop,
complete with NetworkManager applet, I have an NFS mounted home
directory and authenticate using NIS. So I couldn't even get to
the desktop in the first place until the network was up and running.

This is very definitely a bug that needs fixing.
Comment 5 David Cantrell 2009-07-27 21:47:33 EDT
As previously stated, this is as-designed.  These changes first showed up in Fedora 10, which means they've been in the works for quite a while.  For your installation scenario, kickstart offers the capabilities you need.
Comment 6 Tethys 2009-07-28 16:53:00 EDT
No. No, it really doesn't. But since you don't seem inclined to fix
this I guess there's nothing much more I can do. Other than maybe
try and find another distribution that's a bit more user friendly.
Sigh.
Comment 7 Andy Lindeberg 2009-07-29 09:42:07 EDT
Can you explain why kickstart is not a viable option, since it provides a way to work around the issues you are having?

Note You need to log in before you can comment on or make changes to this bug.