Bug 509041 - bugzilla-doc install requirements are excessive
bugzilla-doc install requirements are excessive
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bugzilla (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 20:05 EDT by Bruce Jerrick
Modified: 2009-07-31 05:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-31 05:09:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2009-06-30 20:05:32 EDT
Description of problem:
Installing bugzilla-doc requires too many other major systems.

Version-Release number of selected component (if applicable):
bugzilla-doc-3.2.3-1.fc11.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1. On a system without bugzilla installed, try to install bugzilla-doc .
  
Actual results:
Installation requires bugzilla itself, which in turn requires *many*
Perl modules, a webserver (!), and (at least according to the bugzilla
description) a database system.

Expected results:
bugzilla-doc should be able to be installed without a local bugzilla
installation.

Additional info:
Rationale: bugzilla-doc covers using online bugzilla sites, for
which a local installation of bugzilla (and especially all its
accoutrements) is not necessary.
Comment 1 Emmanuel Seyman 2009-07-19 18:25:57 EDT
(In reply to comment #0)
>
> Installation requires bugzilla itself, which in turn requires *many*
> Perl modules, a webserver (!), and (at least according to the bugzilla
> description) a database system.

Looking into this, it turns out that makedocs.pl (the utility that generates Bugzilla's documentation) is packaged in the bugzilla-doc sub-package.

makedocs.pl pulls in perl(Bugzilla::Install::Requirements) and perl(Bugzilla::Constants) and, hence, the bugzilla package.

Options:

a) make a bugzilla-docs-build sub-package that contains makedocs.pl, the xml files that contain the content, and the docs/lib directory.
b) remove the makedocs.pl script during build. This would impact people who want to modify the xml files and build documentation based on those but I suppose there aren't a lot of those.

Itamar, any input?
Comment 2 Bill McGonigle 2009-07-28 17:14:50 EDT
if b) why not include the makedocs.pl script in the regular bugzilla package?  The docs and the tools to make the docs aren't necessarily the same thing.
Comment 3 Emmanuel Seyman 2009-07-28 18:23:57 EDT
(In reply to comment #2)
>
> if b) why not include the makedocs.pl script in the regular bugzilla package? 

That would make the bugzilla package depend on usr/share/bugzilla/docs and, hence, the bugzilla-doc subpackage.
Comment 4 Emmanuel Seyman 2009-07-31 05:09:08 EDT
I've implemented option a.
bugzilla-doc now depends simply on rpm.

Note You need to log in before you can comment on or make changes to this bug.