Bug 509043 - NUT "did not claim interface before use"
NUT "did not claim interface before use"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 20:32 EDT by Matt Castelein
Modified: 2009-07-01 09:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 09:31:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Castelein 2009-06-30 20:32:29 EDT
Description of problem:
When running NUT, it writes to syslog every 3 seconds like this:
Jun 30 20:25:02 arturo kernel: usb 2-3: usbfs: process 11554 (usbhid-ups) did not claim interface 0 before use
Jun 30 20:25:02 arturo kernel: usb 2-3: usbfs: process 11554 (usbhid-ups) did not claim interface 0 before use
Jun 30 20:25:05 arturo kernel: usb 2-3: usbfs: process 11963 (usbhid-ups) did not claim interface 0 before use
Jun 30 20:25:05 arturo kernel: usb 2-3: usbfs: process 11963 (usbhid-ups) did not claim interface 0 before use
Jun 30 20:25:08 arturo kernel: usb 2-3: usbfs: process 11554 (usbhid-ups) did not claim interface 0 before use
Jun 30 20:25:08 arturo kernel: usb 2-3: usbfs: process 11554 (usbhid-ups) did not claim interface 0 before use
Jun 30 20:25:11 arturo kernel: usb 2-3: usbfs: process 11963 (usbhid-ups) did not claim interface 0 before use
Jun 30 20:25:11 arturo kernel: usb 2-3: usbfs: process 11963 (usbhid-ups) did not claim interface 0 before use
Jun 30 20:25:14 arturo kernel: usb 2-3: usbfs: process 11554 (usbhid-ups) did not claim interface 0 before use
Jun 30 20:25:14 arturo kernel: usb 2-3: usbfs: process 11554 (usbhid-ups) did not claim interface 0 before use

Version-Release number of selected component (if applicable):
nut-2.4.1-6.fc11.x86_64

How reproducible:
always


Additional info:
I am trying to use NUT since updates periodically step on apcupsd. (Bug 346271)
Comment 1 Michal Hlavinka 2009-07-01 02:38:53 EDT
this seems odd, there should not be more than one process.. do you have more than one ups connected?

Try this:
stop ups service
check no usbhid-ups process is running
start ups service

If you get these error messages again, check how many nut processes are running.

thanks
Comment 2 Matt Castelein 2009-07-01 09:31:13 EDT
(In reply to comment #1)
> this seems odd, there should not be more than one process.. do you have more
> than one ups connected?

I have only one.

> Try this:
> stop ups service

[root@arturo ~]# service ups stop
Stopping UPS monitor:                                      [FAILED]
Stopping upsd:                                             [  OK  ]
Shutting down upsdrvctl:                                   [  OK  ]

> check no usbhid-ups process is running

[root@arturo ~]# ps -cAf | grep usbhid-ups
nut      11554     1 TS   19 Jun30 ?        00:00:14 /sbin/usbhid-ups -a br1500lcd

Why didn't it stop?

[root@arturo ~]# pkill usbhid-ups

> start ups service

[root@arturo ~]# service ups start
Starting UPS driver controller:                            [  OK  ]
Starting upsd:                                             [  OK  ]
Starting UPS monitor (master):                             [FAILED]

> If you get these error messages again, check how many nut processes are
> running.
> 
> thanks  

[root@arturo log]# service ups stop
Stopping UPS monitor:                                      [FAILED]
Stopping upsd:                                             [  OK  ]
Shutting down upsdrvctl:                                   [  OK  ]
[root@arturo log]# ps -cAf | grep usbhid-ups

Hmmm.. Not sure why that process was still running.

Note You need to log in before you can comment on or make changes to this bug.