Bug 509067 - Sizes in "Status" column do not sort by size
Sizes in "Status" column do not sort by size
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 02:46 EDT by Richard Schwarting
Modified: 2009-07-16 03:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.27.3-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 05:25:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image where should be sorted descendingly, isn't (116.29 KB, image/png)
2009-07-01 02:46 EDT, Richard Schwarting
no flags Details

  None (edit)
Description Richard Schwarting 2009-07-01 02:46:32 EDT
Created attachment 350062 [details]
Image where should be sorted descendingly, isn't

Description of problem:
"Software Update" window (gpk-update-viewer) has a column "Status" which has the package sizes listed in it.  You can click the column header to, in theory, sort descending or ascending.  However, toggling it between either doesn't sort in either way.  

Version-Release number of selected component (if applicable):
2.27.2

How reproducible:
Both times I've tried.  

Steps to Reproduce:
1. Open the "Software Update" window when there are updates.
2. Click "Status", the header for the column containing sizes
  
Actual results:
The column does not sort itself.

Expected results:
The column should sort itself.  Since it contains sizes, it should sort numerically (though with 1MB > 100KB, of course :)

Additional info:
Comment 1 Richard Hughes 2009-07-01 05:07:49 EDT
It sorts by status, i.e. downloading, downloaded, installing... why do you want to sort by size?
Comment 2 Richard Schwarting 2009-07-01 05:13:42 EDT
Before I begin installing the updates, as the attached screenshot shows, it displays the sizes of the files down the "Status" column.  Due to bandwidth constraints, I sometimes find it worthwhile to upgrade to all but the biggest things.  (Though, I suppose Presto on Fedora can help with the cause.)  

Regardless, the UI exposes a column that can be sorted, where the content (at the time, package sizes) does not appear to sort (since I suppose it doesn't care about the size it's displaying, but the status it's not displaying, at the time).
Comment 3 Richard Hughes 2009-07-01 05:25:57 EDT
(In reply to comment #2)
> Due to bandwidth
> constraints, I sometimes find it worthwhile to upgrade to all but the biggest
> things.

Right, that's a fair use case.

> Regardless, the UI exposes a column that can be sorted, where the content (at
> the time, package sizes) does not appear to sort (since I suppose it doesn't
> care about the size it's displaying, but the status it's not displaying, at the
> time).  

Right, and that's just bad usability. I've fixed this upstream:

commit 1103b7443f3a6757a153c22068829c7b147d962f
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Jul 1 10:23:54 2009 +0100

    Don't include the size column in the Status column. Fixes rh#509067

New release is scheduled for next Monday. Thanks.
Comment 4 Richard Schwarting 2009-07-01 05:31:24 EDT
Thanks for handling this!
Comment 5 Fedora Update System 2009-07-06 08:34:41 EDT
gnome-packagekit-2.27.3-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnome-packagekit-2.27.3-1.fc11
Comment 6 Fedora Update System 2009-07-16 03:24:00 EDT
gnome-packagekit-2.27.3-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.