Bug 509104 - Make packagekit not actually check for updates ever
Make packagekit not actually check for updates ever
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 513467 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 07:56 EDT by Josef Bacik
Modified: 2009-07-23 15:14 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.27.3-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 08:57:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Bacik 2009-07-01 07:56:38 EDT
Even with all of the updates options set to "Never" the update thing will still run immediately after running a yum command.  Can we please make never actually mean never?  I don't want to remove packagekit since I like the other features it has, I just don't like it making my box slow down to a crawl while it tries to figure out what updates I'm missing.
Comment 1 Richard Hughes 2009-07-01 08:57:40 EDT
Cool, good catch. I've applied this:

commit cba7459514e19fc1ab9b1333f6dd2c402329d793
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Jul 1 13:55:49 2009 +0100

    If the use has set get-updates policy to never, then ignore updates-changed events. Fixes rh#509104

New release out next Monday.
Comment 2 Fedora Update System 2009-07-06 08:34:45 EDT
gnome-packagekit-2.27.3-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnome-packagekit-2.27.3-1.fc11
Comment 3 Fedora Update System 2009-07-16 03:24:05 EDT
gnome-packagekit-2.27.3-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Richard Hughes 2009-07-23 15:14:37 EDT
*** Bug 513467 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.