Bug 509108 - Cannot install VLC media player
Cannot install VLC media player
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libxcb (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 08:19 EDT by Răzvan Sandu
Modified: 2009-07-06 11:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 11:06:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2009-07-01 08:19:14 EDT
Description of problem:

Hello,

Trying to install VLC on Fedora 11, with rpmfusion activated, I get this:


[root@localhost ~]# yum -y --obsoletes install vlc
Loaded plugins: dellsysidplugin2, downloadonly, fastestmirror, priorities, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: ftp.informatik.uni-frankfurt.de
 * rpmfusion-free: ftp.nb.lug.ro
 * rpmfusion-free-updates: ftp.nb.lug.ro
 * rpmfusion-nonfree: ftp.nb.lug.ro
 * rpmfusion-nonfree-updates: ftp.nb.lug.ro
 * updates: mirror.karneval.cz
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package vlc.i586 0:1.0.0-0.11rc3.fc11 set to be updated
--> Processing Dependency: vlc-core = 1.0.0-0.11rc3.fc11 for package: vlc-1.0.0-0.11rc3.fc11.i586
--> Processing Dependency: libvlccore.so.2 for package: vlc-1.0.0-0.11rc3.fc11.i586
--> Running transaction check
---> Package vlc-core.i586 0:1.0.0-0.11rc3.fc11 set to be updated
--> Processing Dependency: libxcb-keysyms.so.0 for package: vlc-core-1.0.0-0.11rc3.fc11.i586
--> Finished Dependency Resolution
vlc-core-1.0.0-0.11rc3.fc11.i586 from rpmfusion-free has depsolving problems
  --> Missing Dependency: libxcb-keysyms.so.0 is needed by package vlc-core-1.0.0-0.11rc3.fc11.i586 (rpmfusion-free)
Error: Missing Dependency: libxcb-keysyms.so.0 is needed by package vlc-core-1.0.0-0.11rc3.fc11.i586 (rpmfusion-free)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Best regards,
Răzvan
Comment 1 Adam Jackson 2009-07-06 11:06:29 EDT
rpmfusion bug, libxcb-keysyms is .so.1 in F-11 now.

I've fixed xcb-util to explicitly list DSO versions though, so we'll catch this sort of thing in the future.

Note You need to log in before you can comment on or make changes to this bug.