Bug 509194 - Clicking on iss synced channels pkg # causes ise
Clicking on iss synced channels pkg # causes ise
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Tomas Lestach
https://riverraid.rhndev.redhat.com/r...
:
Depends On:
Blocks: 457071 509195
  Show dependency treegraph
 
Reported: 2009-07-01 13:37 EDT by wes hayutin
Modified: 2009-09-10 16:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 509195 (view as bug list)
Environment:
Last Closed: 2009-09-10 16:04:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-07-01 13:37:44 EDT
Description of problem:

6/25 rhel 5 

ISS synced channels are not really available via the webui.

1.Sync a custom channel from a parent to a slave.
2. go to the webui of the slave -> channels, manage channels
3. click the # of packages for that channel.

result = ise
2009-07-01 13:29:07,776 [TP-Processor3] WARN  org.apache.struts.action.RequestProcessor - Unhandled Exception thrown: class java.lang.NullPointerException
2009-07-01 13:29:07,799 [TP-Processor3] ERROR com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction. Rolling back
javax.servlet.ServletException
        at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:237)
        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
        at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
        at java.lang.Thread.run(Thread.java:735)
Caused by: 
java.lang.NullPointerException
        at com.redhat.rhn.manager.user.UserManager.verifyChannelRole(UserManager.java:140)
        at com.redhat.rhn.manager.user.UserManager.verifyChannelAdmin(UserManager.java:121)
        at com.redhat.rhn.frontend.action.channel.manage.ChannelPackagesAction.execute(ChannelPackagesAction.java:68)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        ... 40 more
2009-07-01 13:29:07,809 [TP-Processor3] ERROR org.apache.catalin
Comment 1 wes hayutin 2009-07-01 16:23:49 EDT
this channel and test was performed in a new org.. not org1
Comment 3 Fedora Update System 2009-07-02 15:00:24 EDT
offlineimap-6.1.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/offlineimap-6.1.0-2.fc11
Comment 4 Tomas Lestach 2009-07-13 08:24:21 EDT
I created a custom channel and pushed couple of packages into it.

Syncing the custom channel into sat compose from 09/06/12:
 -> accessing /rhn/software/channels/All.do, custom channel isn't visible at all on webui
 -> accessing /rhn/channels/manage/Manage.do, the channel name and number of packages are displayed, but clicking either on the channel name or on the package number -> invokes an error

Syncing the same custom channel into sat compose from 09/07/09:
 -> accessing /rhn/software/channels/All.do, custom channel *is* visible on webui
 -> accessing /rhn/channels/manage/Manage.do, the channel name and number of packages are displayed, and both links refer to existing pages

VERIFIED
Comment 5 Fedora Update System 2009-07-17 10:13:45 EDT
offlineimap-6.1.2-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/offlineimap-6.1.2-1.fc11
Comment 6 Preethi Thomas 2009-08-07 15:51:25 EDT
Release Pending
iss parent:
sun-x4200-01.rhts.bos.redhat.com org:103
slave test04-64.rhndev.redhat.com the next org to be created 103
created pttest with 2 packages
synced pttest to test04-64
channel & package accessible
Comment 7 Brandon Perkins 2009-09-10 16:04:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.