Bug 509198 - Package Not found error on syncing redhat channels on ISS
Package Not found error on syncing redhat channels on ISS
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Preethi Thomas
:
Depends On:
Blocks: 457071
  Show dependency treegraph
 
Reported: 2009-07-01 13:56 EDT by Preethi Thomas
Modified: 2009-09-10 16:04 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:04:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-07-01 13:56:18 EDT
Description of problem:

Package Not found error on syncing redhat channels on ISS
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Set up Master/Slave fro ISS
2.sync -c redhat channel
3.
  
Actual results:
Error Message:
    Package not found
Error Class Code: 17
Error Class Info: File not found.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


Expected results:


Additional info:
13:14:13
SYNC ERROR:

Exception reported from fjs-0-13.rhndev.redhat.com
Time: Wed Jul  1 13:14:13 2009
Exception type satellite_tools.syncLib.RhnSyncException

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/satellite-sync", line 142, in main
    return satsync.Runner().main()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 211, in main
    ret = method()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 313, in _step_rpms
    self._packages_report = self.syncer.download_rpms()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1025, in download_rpms
    self._fetch_packages(channel, missing_fs_packages)
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1822, in _fetch_packages
    package_id, nvrea, sources)
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1905, in _get_package_stream
    stream  = self.xmlWireServer.getRpm(nvrea, channel)
  File "/usr/share/rhn/satellite_tools/xmlWireSource.py", line 266, in getRpm
    (self.systemid, package_name, channel))
  File "/usr/share/rhn/satellite_tools/xmlWireSource.py", line 170, in _openSocketStream
    raise RhnSyncException, lastErrorMsg
RhnSyncException:
Error Message:
    Package not found
Error Class Code: 17
Error Class Info: File not found.
Explanation:
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
Comment 1 Clifford Perry 2009-07-01 16:10:24 EDT
This seems to be broken due to packages being deleted from /var/satellite on the shared NFS mount. Moving back to ON_QA. Please make sure clean satellite-sync of content. 

Cliff
Comment 2 Preethi Thomas 2009-07-07 21:44:48 EDT
verified
Satellite-5.3.0-RHEL5-re20090702.0-i386-embedded-oracle.iso
Comment 3 Michael Mráka 2009-08-11 08:13:52 EDT
Verified in stage -> RELEASE_PENDING.

# satellite-sync -c custom-centos5
14:12:39 Red Hat Network Satellite - live synchronization
14:12:39    url: https://dell-pem905-01.rhts.bos.redhat.com
...
    Import complete:
        Begin time: Tue Aug 11 14:12:39 2009
        End time:   Tue Aug 11 14:12:57 2009
        Elapsed:    0 hours, 0 minutes, 18 seconds
Comment 4 Brandon Perkins 2009-09-10 16:04:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.