Bug 509221 - multi-arch, listing packages shows, x86_64, installing packages shows AMD64
multi-arch, listing packages shows, x86_64, installing packages shows AMD64
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
wes hayutin
https://rhndev5.z900.redhat.com/rhn/s...
:
Depends On:
Blocks: 471789
  Show dependency treegraph
 
Reported: 2009-07-01 15:35 EDT by wes hayutin
Modified: 2009-09-10 14:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:44:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-07-01 15:35:56 EDT
Description of problem:

build 5/26 rhel 5 

multi-arch, listing packages shows, x86_64, installing packages shows AMD64

recreate:
1. register a rhel53 x86_64 boxl 
2. go to sdc, list packages
note the packages w/ x86_64

3. go to sdc, install packages
note RHEL5 packages w/ AMD64


Further...
go to a @base system x86_64, go to install page.
install zsh, notice that the arch is AMD64

install it, rhn_check

now use the webui to list the package.
The arch is now listed as x86_64

boog :)
Comment 1 Clifford Perry 2009-07-01 16:02:08 EDT
Approved
Comment 2 Brad Buckingham 2009-07-01 16:39:10 EDT
master git commit: 6faa879a0a41ee68706d18c2de7e5ec0ce84c85c
vader git commit: e7e79d422c363f81508192e6acc6e0e2bb007f08

Looks like the problem was that the query used by the List/Remove page was using the rhnPackageArch.label and the Install page was rhnPackageArch.name.  For the 64-bit arch, these values are different.  Updated the Install page to use rhnPackageArch.label which is the more correct value.
Comment 3 John Sefler 2009-07-06 10:33:06 EDT
verifed 7/3 build
Comment 4 Brandon Perkins 2009-08-07 16:39:00 EDT
Release Pending.  All is x86_64 now.
Comment 5 Brandon Perkins 2009-09-10 14:44:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.