Bug 509226 - (systemlogviewer) (gnome-system-log:7845): GLib-CRITICAL **: g_date_subtract_years: assertion `d->year > nyears' failed
(gnome-system-log:7845): GLib-CRITICAL **: g_date_subtract_years: assertion `...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-utils (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 16:02 EDT by bhulst
Modified: 2009-09-13 13:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-13 13:53:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug_systemlog.png (53.59 KB, image/png)
2009-07-01 16:03 EDT, bhulst
no flags Details

  None (edit)
Description bhulst 2009-07-01 16:02:10 EDT
Description of problem:
The gnome-system-log application is showing each year in the log with a new year counting down from the current year. See the screenshot.
The actual error comes when running it from the xterminal:
A few hundred of these messages appear.
(gnome-system-log:7845): GLib-CRITICAL **: g_date_subtract_years: assertion `d->year > nyears' failed

Version-Release number of selected component (if applicable):
glib-1.2.10-32.fc10.i386
glib-1.2.10-32.fc10.x86_64
gnome-utils-2.24.1-1.fc10.x86_64
gnome-utils-2.24.1-1.fc10.i386

Steps to Reproduce:
1. start gnome-system-log from menu or cli.
Comment 1 bhulst 2009-07-01 16:03:21 EDT
Created attachment 350183 [details]
bug_systemlog.png
Comment 2 bhulst 2009-09-13 13:53:13 EDT
Today I changed the file /etc/rsyslog.conf since I noticed the old Fedora 8 version was still in use. Now with the version 3 the System Log Viewer is given a proper date format.

The file /var/log/messages changed data format:

2009-09-13T18:18:17.294254+03:00 localhost rsyslogd: [origin software="rsyslogd" swVersion="3.22.1" x-pid="2128" x-info="http://www.r
syslog.com"] exiting on signal 15.
Sep 13 18:18:20 localhost kernel: imklog 3.22.1, log source = /proc/kmsg started.
Sep 13 18:18:20 localhost rsyslogd: [origin software="rsyslogd" swVersion="3.22.1" x-pid="6280" x-info="http://www.rsyslog.com"] (re)
start

Now the system log view is able to parse the messages logfile.

Note You need to log in before you can comment on or make changes to this bug.