Bug 509232 - Firefox scrolls varying number of pages per click
Firefox scrolls varying number of pages per click
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 16:24 EDT by Pete Zaitcev
Modified: 2009-09-12 17:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-12 17:52:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2009-07-01 16:24:40 EDT
Description of problem:

If I click into vertical scrollbar of Firefox, the document may scroll
varying number of pages.

Version-Release number of selected component (if applicable):

kernel-2.6.31-0.35.rc1.git5.fc12.x86_64
xorg-x11-server-Xorg-1.6.99-8.20090618.fc12.x86_64
xorg-x11-drv-ati-6.12.2-19.fc12.x86_64
xorg-x11-drv-synaptics-1.1.99-1.20090622.fc12.x86_64
firefox-3.5-0.21.beta4.fc12.x86_64

How reproducible:

It only reporduces on one computer.
Reproduction is reliable on that computer.
But the problem does not occure on every click.

Steps to Reproduce:
1. Open a long document in Firefox
2. Click into scrollbar below scroller
  
Actual results:

Excessive scroll

Expected results:

Scroll by 1 page

Additional info:

I only put this before the feet of synaptics tentatively, to document
circumstances and software set. This may be a bug in Firefox, or a bug
in X server. When I had a bug like that in synaptics before, other
applications were affected, but so far it appears that no other
application is (tried vim-X11, Sylpheed, evince).

Also, the last time it was a logic issue in synaptics that made it
forget the button status. So, the scrollbar scrolled like crazy until
I moved finger or produced other event. This time it's different:
the uncommanded scroll stops by itself after less than a second.
Comment 1 Pete Zaitcev 2009-07-01 16:28:03 EDT
I forgot to mention that this started after the upgrade yesterday.
Unfortunately, there was a big gap in upgrade sequence on this box, the
previous synaptics driver was xorg-x11-drv-synaptics-1.1.0-7.fc11.x86_64,
installed on May 26.

Also, I tried to run synclient -m 1, but it asks for SHMconfig and
I forgot how to set it.
Comment 2 Peter Hutterer 2009-07-01 18:25:55 EDT
I'd need some more details please:
- how do you click? tap? physical buttons? other buttons? 
- does it happen with other methods of clicking (tapping, physical buttons, etc.)
- can it be a timeout issue? holding the button for a tad longer causes more scrolling, so maybe you're hitting just that magical threshold (that's a timeout in firefox afaict)
- does it happen with a standard usb mouse?



> Also, I tried to run synclient -m 1, but it asks for SHMconfig and
> I forgot how to set it.  

https://fedoraproject.org/wiki/Input_device_configuration, the key is input.x11_driver.SHMConfig.

to narrow down whether it is in fact synaptics, you could also move /usr/share/hal/fdi/policies/20thirdparty/10-synaptics.fdi out of the way, restart HAL + X and then try again. this should load the evdev driver for the touchpad - which will feel a bit different but should still work (no tapping though). does the problem still happen?
Comment 3 Pete Zaitcev 2009-07-06 15:34:30 EDT
The problem is gone after an update.

kernel-2.6.31-0.42.rc2.fc12.x86_64      <----------------- changed
xorg-x11-server-Xorg-1.6.99-8.20090618.fc12.x86_64
xorg-x11-drv-ati-6.12.2-19.fc12.x86_64
xorg-x11-drv-synaptics-1.1.99-1.20090622.fc12.x86_64
firefox-3.5-1.fc12.x86_64               <----------------- changed

I suspect it was Firefox, or Firefox triggering something in GTK2.
Comment 4 Pete Zaitcev 2009-07-07 19:16:28 EDT
Oh joy, it's still here. Apparently needs a background CPU load to reproduce
reliably. Reopening...  I'll address questions from comment #2 in a moment.
Comment 5 Pete Zaitcev 2009-07-07 19:47:34 EDT
I'm switching the component to firefox, because:
 - this is reproducible with a USB touchpad
 - Firefox is the only application that fails

It may be something in GTK2, and Firefox only triggering it, but I honestly
have no idea. I need an expert to look at it.

I create a CPU load by building kernels, this helps reproduce it easily.
This very bug in Bugzilla serves as a test webpage.
Comment 6 Pete Zaitcev 2009-08-06 13:27:34 EDT
The problem is gone with update to firefox-3.5.2-2.fc11.x86_64. However,
comments by Christopher in bug 515772 suggest that it was built with old
toolchain, presumably in old buildroot. So, we may almost be certain
that the problem is not in Firefox as such, but in some library it uses
on F12.
Comment 7 Pete Zaitcev 2009-08-11 12:29:27 EDT
Something new every release. The problem is back but at least now that
Firefox gets a stuck and/or lost event and starts scrolling unstoppably,
it will stop (eventually) if I click like mad into the uppper region of
the scrollbar. Before, it was necessary to wait until it scrolls to
the bottom stop.

firefox-3.5.2-3.fc12.x86_64
gtk2-2.17.6-4.fc12.x86_64
glibc-2.10.90-12.x86_64
Comment 8 Pete Zaitcev 2009-09-12 17:52:13 EDT
Looks like it fixed itself now.

firefox-3.5.3-1.fc12.x86_64
gtk2-2.17.11-2.fc12.x86_64
glibc-2.10.90-21.x86_64

Note You need to log in before you can comment on or make changes to this bug.