Bug 509250 - Conflict when using boost filesystem and c++0x
Conflict when using boost filesystem and c++0x
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Benjamin Kosnik
Fedora Extras Quality Assurance
https://svn.boost.org/trac/boost/tick...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 16:58 EDT by john5342
Modified: 2013-08-09 01:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.37.0-7.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-25 16:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john5342 2009-07-01 16:58:03 EDT
Description of problem:
When compiling with g++ using the -std=c++0x the tr1 component of the standard library gets pulled in and this conflicts with boost/filesystem/operations.hpp making boost.filesystem useless. This bug is probably also found when using tr1 directly at the same time as boost.filesystem.

Version-Release number of selected component (if applicable):
boost-1.37.0-6.fc11
boost-devel-1.37.0-6.fc11

How reproducible:
Always

Steps to Reproduce:
1. Write any code that makes use of boost filesystem
2. Compile with -std=c++0x
  
Actual results:
Compilation fails due to name collisions/conflicts

Expected results:
Compilation succeeds as expected

Additional info:
Full error messages and a patch are available upstream. Link to upstream bug provided. Only the boost/filesystem/operations.hpp portion of the patch is actually required since boost itself is not compiled with this option. The patch does not break anything and does not effect abi (therefore no rebuilding of deps required).

Backporting this patch would be very much appreciated. Thanks in advance
Comment 1 Petr Machata 2009-07-02 13:27:38 EDT
Turns out that no backporting is necessary, the patch applies flawlessly as it is.  I've included it and built new boost release.  Can you report back whether it fixes your problem?
Comment 2 john5342 2009-07-02 14:15:19 EDT
I am using Fedora 11 but only new builds appear to be for Fedora 12. I have however already confirmed that the header modification solves the problem by manually editing the header file as per the patch on my local system.
Comment 3 Petr Machata 2009-07-03 06:18:31 EDT
Sorry, I don't know why I though that your problem is with Rawhide package.  I'll spin F11 fix later today.
Comment 4 Fedora Update System 2009-07-03 09:20:10 EDT
boost-1.37.0-7.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/boost-1.37.0-7.fc11
Comment 5 Fedora Update System 2009-07-11 12:59:49 EDT
boost-1.37.0-7.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update boost'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7430
Comment 6 Fedora Update System 2009-09-25 16:15:13 EDT
boost-1.37.0-7.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.