Bug 509262 - Attempting to remove only an i386 package from x86_64 box also removes x86_64 package
Attempting to remove only an i386 package from x86_64 box also removes x86_64...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Jeff Browning
:
Depends On:
Blocks: 471789
  Show dependency treegraph
 
Reported: 2009-07-01 17:34 EDT by Jeff Browning
Modified: 2009-09-10 14:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:44:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Browning 2009-07-01 17:34:44 EDT
Description of problem:
When trying to uninstall only the i386 version of a package from an x86_64 box, the x86_64 package of the same name is also removed.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Install both i386 and x86_64 versions of the same package onto an x86_64 box (The version used in my case was RHEL5u3)
2. Schedule to remove only the i386 version of the package.
3. Run rhn_check
  
Actual results:
Both the i386 and x86_64 packages are removed.

Expected results:
Only the specified version of the package should have been removed.

Additional info:
Comment 2 Clifford Perry 2009-07-01 22:24:47 EDT
The RHEL 5.3 client does not have this code fix. This was/should be fixed within the RHEL 5.4 beta client code - see bug 476899 tracking the RHEL 5.4 release. 

Please re-test this with the RHEL 5.4 client. To me looks like the server side (from rhn_check output) correctly sent down the arch information needed. 

Thanks,
Cliff
Comment 3 Jeff Browning 2009-07-06 15:17:29 EDT
Confirmed. 5.4 client performs as expected.
Comment 4 Brandon Perkins 2009-08-11 10:43:11 EDT
Release Pending.  Used z205.z900.redhat.com as the client, test1182.test.redhat.com as the Satellite, with the following RHN client packages:

rhnlib-2.2.7-2.el5
rhnsd-4.7.0-4.el5
rhn-client-tools-0.4.20-9.el5
rhn-setup-0.4.20-9.el5
yum-rhn-plugin-0.5.4-13.el5
rhn-check-0.4.20-9.el5
Comment 5 Brandon Perkins 2009-09-10 14:44:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.