Bug 509270 - misleading text on software channels page
misleading text on software channels page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Milan Zazrivec
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-07-01 19:08 EDT by Pradeep Kilambi
Modified: 2009-09-10 16:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:38:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
All channels page (130.90 KB, application/octet-stream)
2009-07-01 19:10 EDT, Pradeep Kilambi
no flags Details
All channels page (130.90 KB, image/jpeg)
2009-07-01 19:11 EDT, Pradeep Kilambi
no flags Details

  None (edit)
Description Pradeep Kilambi 2009-07-01 19:08:28 EDT
Description of problem:

If you look at 

https://riverraid.rhndev.redhat.com/rhn/software/channels/All.do?

This tab shows all available channels including custom, but the text reads

"The software channels listed below are all of the channels that your organization is entitled to and are currently supported by Red Hat. "

Since custom channels are not supported by redhat this part should only be shown if we're in redhat channels tab.

https://riverraid.rhndev.redhat.com/rhn/software/channels/RedHat.do?

screenshot follows.
Comment 1 Pradeep Kilambi 2009-07-01 19:10:41 EDT
Created attachment 350221 [details]
All channels page

As you can see 20-test is a custom channel. The bolded test is correct. As its say ' all of the channels'. But the second part I think can be misleading. minor bug so dont care if its punted.
Comment 2 Pradeep Kilambi 2009-07-01 19:11:59 EDT
Created attachment 350222 [details]
All channels page
Comment 3 Clifford Perry 2009-07-01 22:06:27 EDT
This is new code/structure added by Justin for 530. Approving to fix the text on the pages before it hits customers - should be easy. 

Cliff
Comment 4 Brad Buckingham 2009-07-02 10:36:25 EDT
master git commit: 958ee2369ca6e72b9326b30bb3994dbbefbac8b2
vader git commit: 7ee7ed161f2fb463eb6b4510b887cd3be54f97e0

Updated text on "All Channels" to read:

The software channels listed below are all of the channels that your organization has access to.
Comment 5 Milan Zazrivec 2009-07-07 08:09:48 EDT
Verified, spacewalk-java-0.5.44-27
Comment 6 Miroslav Suchý 2009-08-17 08:32:33 EDT
verified in stage
Comment 7 Brandon Perkins 2009-09-10 16:38:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.