Bug 50932 - util-linux-2.11f-8 should obsolete kbd?
Summary: util-linux-2.11f-8 should obsolete kbd?
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: Xconfigurator   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-05 02:37 UTC by Eugene Kanter
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 16:36:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eugene Kanter 2001-08-05 02:37:30 UTC
Description of Problem:

rpm -Fvh $(ls *.rpm | grep -v kernel| grep -v i686) --test
Preparing...                ########################################### [100%]
file /sbin/kbdrate from install of util-linux-2.11f-8 conflicts with file
from package kbd-1.06-6
file /usr/share/man/man8/kbdrate.8.gz from install of util-linux-2.11f-8
conflicts with file from package kbd-1.06-6


Analysis:

kbd seems to be removed from rawhide and it is not present in 7.2 public beta.

Looks like util-linux should contain

obsoletes: kbd

or something like this in its .spec file.

Comment 1 Elliot Lee 2001-08-05 18:30:02 UTC
console-tools obsoletes kbd.

Comment 2 Eugene Kanter 2001-08-06 13:49:01 UTC
Ok, but I am courious why Xconfigurator depends on kbd?

Comment 3 Elliot Lee 2001-08-06 16:34:47 UTC
Reopening, assigning to Xconfigurator

Comment 4 Mike A. Harris 2001-08-13 04:43:05 UTC
* Thu Sep 17 1998 Preston Brown <pbrown@redhat.com>
- fixed problem with path to keyboard map being wrong with new kbd package

I dunno what the dep is but I am not removing it unless someone says
it shouldn't be there and gives a good reason why.  No sense wasting
time on proving each dep in a package is valid.

Comment 5 Mike A. Harris 2001-08-13 04:44:32 UTC
console-tools should if it doesn't already, have a Provides: kbd

Comment 6 Eugene Kanter 2001-08-13 14:38:26 UTC
console-tools has Provides: kbd.
no more questions.


Note You need to log in before you can comment on or make changes to this bug.