Bug 50932 - util-linux-2.11f-8 should obsolete kbd?
util-linux-2.11f-8 should obsolete kbd?
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: Xconfigurator (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-04 22:37 EDT by Eugene Kanter
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 12:36:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2001-08-04 22:37:30 EDT
Description of Problem:

rpm -Fvh $(ls *.rpm | grep -v kernel| grep -v i686) --test
Preparing...                ########################################### [100%]
file /sbin/kbdrate from install of util-linux-2.11f-8 conflicts with file
from package kbd-1.06-6
file /usr/share/man/man8/kbdrate.8.gz from install of util-linux-2.11f-8
conflicts with file from package kbd-1.06-6


Analysis:

kbd seems to be removed from rawhide and it is not present in 7.2 public beta.

Looks like util-linux should contain

obsoletes: kbd

or something like this in its .spec file.
Comment 1 Elliot Lee 2001-08-05 14:30:02 EDT
console-tools obsoletes kbd.
Comment 2 Eugene Kanter 2001-08-06 09:49:01 EDT
Ok, but I am courious why Xconfigurator depends on kbd?
Comment 3 Elliot Lee 2001-08-06 12:34:47 EDT
Reopening, assigning to Xconfigurator
Comment 4 Mike A. Harris 2001-08-13 00:43:05 EDT
* Thu Sep 17 1998 Preston Brown <pbrown@redhat.com>
- fixed problem with path to keyboard map being wrong with new kbd package

I dunno what the dep is but I am not removing it unless someone says
it shouldn't be there and gives a good reason why.  No sense wasting
time on proving each dep in a package is valid.
Comment 5 Mike A. Harris 2001-08-13 00:44:32 EDT
console-tools should if it doesn't already, have a Provides: kbd
Comment 6 Eugene Kanter 2001-08-13 10:38:26 EDT
console-tools has Provides: kbd.
no more questions.

Note You need to log in before you can comment on or make changes to this bug.