Bug 509340 - uuid got by command "wmic csproduct" in windows guest does not match the uuid number set in CLI.
uuid got by command "wmic csproduct" in windows guest does not match the uuid...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Eduardo Habkost
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 06:29 EDT by Miya Chen
Modified: 2014-03-25 20:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 21:24:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miya Chen 2009-07-02 06:29:29 EDT
Description of problem:
uuid got by command "wmic csproduct" in windows guest does not match the uuid number set in CLI.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.start windows xp guest by:
/usr/libexec/qemu-kvm -drive file=winxp-32.qcow2,if=ide -net nic,macaddr=20:20:20:78:69:29 -net tap,script=/mnt/images/qemu-ifup -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2 -m 2048 -uuid 7af7c031-b321-402c-9c2f-3c359bf43948 -vnc :20
2.Type command "wmic csproduct" in cmd.

  
Actual results:
uuid got in the output of "wmic csproduct" is 31c0f77a-21b3-2c40-9c2f-3c359bf43948

Expected results:
uuid number got by command "wmic csproduct" should be same with the uuid number set in commandline "-uuid".

Additional info:
win28k and win23k have the same problem.
Comment 1 Yaniv Kaul 2009-07-02 07:14:24 EDT
Looks like a simply endianity issue. It's just the way UUIDs are parsed that is different.
If you compare the input:
7af7c031-b321-402c-9c2f-3c359bf43948
and the output in the VM:
31c0f77a-21b3-2c40-9c2f-3c359bf43948

You'll see clearly that it's just changing [0][1][2][3]-[4][5]... with [3][2][1][0]-[5][4]-...

I'd close this bug.
Comment 2 Miya Chen 2009-07-02 21:24:02 EDT
according comment1, close this bug.

Note You need to log in before you can comment on or make changes to this bug.