Bug 509362 - CLI Proxy install on s390x fails
CLI Proxy install on s390x fails
Status: CLOSED DUPLICATE of bug 506264
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
s390x Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
John Matthews
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 09:15 EDT by John Matthews
Modified: 2009-07-02 11:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 11:06:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2009-07-02 09:15:19 EDT
Description of problem:

Install of CLI proxy on s390x machine is failing

API version: 5.3.0

There was a problem activating the RHN Proxy entitlement:
ERROR: upon entitlement/activation attempt: unknown error - <Fault 1046: 'redstone.xmlrpc.XmlRpcFault: proxy_channel_not_found'>
Proxy activation failed! Installation interrupted.
API version: 5.3.0
RHN Proxy successfully deactivated.



Version-Release number of selected component (if applicable):


How reproducible:
Duplicated this failure 5 times.

Steps to Reproduce:
1. Sync 5.3 proxy for s390x on a Sat
2. Register s390x client (from RHTS) to sat
3. Setup configuration file deployment
4. Install spacewalk-proxy-installer
5. configure-proxy.sh
6. Answer questions from CLI
  
Actual results:
[root@z206 ~]# rpm -qa | grep proxy
spacewalk-proxy-installer-0.5.25-13.el5sat
[root@z206 ~]# configure-proxy.sh 
RHN Parent [rhndev5.z900.redhat.com]: 
Proxy version to activate []: 5.3
Traceback email []: jmatthew@redhat.com
Use SSL [Y/n]: 
CA Chain [/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT]: 
HTTP Proxy []: 
Regardless of whether you enabled SSL for the connection to the Spacewalk Parent
Server, you will be prompted to generate an SSL certificate.
This SSL certificate will allow client systems to connect to this Spacewalk Proxy
securely. Refer to the Spacewalk Proxy Installation Guide for more information.
Organization []: Red Hat
Organization Unit [z206.z900.redhat.com]: 
Common Name [z206.z900.redhat.com]: 
City []: Raleigh
[root@z206 ~]# configure-proxy.sh 
RHN Parent [rhndev5.z900.redhat.com]: 
Proxy version to activate []: 5.3
Traceback email []: jmatthew@redhat.com
Use SSL [Y/n]: 
CA Chain [/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT]: 
HTTP Proxy []: 
Regardless of whether you enabled SSL for the connection to the Spacewalk Parent
Server, you will be prompted to generate an SSL certificate.
This SSL certificate will allow client systems to connect to this Spacewalk Proxy
securely. Refer to the Spacewalk Proxy Installation Guide for more information.
Organization []: Red Hat
Organization Unit [z206.z900.redhat.com]: rhndev5.z900.redhat.com
Common Name [z206.z900.redhat.com]: rhndev5.z900.redhat.com
City []: Raleigh
State []: NC
Country code []: US
Email [jmatthew@redhat.com]: 
API version: 5.3.0

There was a problem activating the RHN Proxy entitlement:
ERROR: upon entitlement/activation attempt: unknown error - <Fault 1046: 'redstone.xmlrpc.XmlRpcFault: proxy_channel_not_found'>
Proxy activation failed! Installation interrupted.
API version: 5.3.0
RHN Proxy successfully deactivated.

Expected results:
Proxy should activate

Additional info:
Comment 1 John Matthews 2009-07-02 09:16:52 EDT
I was able to install the WebUI version of the s390x satellite without errors.

CLI is breaking for me.
Comment 4 Miroslav Suchý 2009-07-02 11:06:44 EDT

*** This bug has been marked as a duplicate of bug 506264 ***

Note You need to log in before you can comment on or make changes to this bug.