Bug 50937 - installer crash after selected packages exceeded /usr partitioned disk space
Summary: installer crash after selected packages exceeded /usr partitioned disk space
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-05 07:05 UTC by Todd H
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 19:04:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump file from installer (917 bytes, text/plain)
2001-08-05 07:06 UTC, Todd H
no flags Details

Description Todd H 2001-08-05 07:06:52 UTC
Created attachment 26275 [details]
Anaconda dump file from installer

Comment 1 Brent Fox 2001-08-06 16:47:54 UTC
It looks like the problem is related to the NTFS partitions on your system.  Did
you try to reformat them or set mount points for them.

Comment 2 Todd H 2001-08-06 19:04:14 UTC
It may be related to ntfs, but I don't think it's the root cause.  

When the crash occurred, it happened after accepting the "insufficient disk 
space in /usr partition" dialog box.   I was able to repeat this 3 times with 3 
different attempts at selecting few enough packages to fit in my ~800Mb /usr 
partition.  Each time, I formatted the / and /usr partitions, and each time I 
had specified mount points for my two existing ntfs partitions. 

I successfully completed an installation when I broke up my 800mb partition I 
was using for /usr into 200Mb for /usr/X11R6  and 600Mb for /usr/lib.  The 
installation then completed successfully despite my specifying mount points for 
my two ntfs partitions.  

As such, I think the error in an unhandled condition in the routine that 
verifies available disk space.   To replicate the error, I'd try creating a 
disk with a primary FAT16 partition, a Linux native / partition of 800Mb  a 
linux native /usr partition of 800Mb, and throwing a pair of ntfs partitions in 
for good measure, and then attempting a workstation class ftp-based install. 



Comment 3 Matt Wilson 2001-08-15 21:10:46 UTC
ntfs isn't supported; don't make mount points for your filesystems.  The next
release won't let you mount ntfs filesystems.



Note You need to log in before you can comment on or make changes to this bug.