Bug 509370 - Default aide.conf incorrect.
Default aide.conf incorrect.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aide (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Steve Grubb
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 10:02 EDT by Drew Ogle
Modified: 2009-08-19 17:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-19 17:51:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Drew Ogle 2009-07-02 10:02:47 EDT
Description of problem:

Supplied Configration File does not monitor only "admin dot files for PERMS"


Version-Release number of selected component (if applicable):

Exists in 0.13.1-7.fc11

How reproducible:

Every time.


Steps to Reproduce:
1. Install aide.
2. Run aide -i
3. move the db in place.
4. run aide -C, note everything is fine.
5. change the mtime on a non dot file in /root.
6. run aide -C, note the mtime change is not reported.
  
Actual results:

mtime change on normal file in /root not reported.

Expected results:

mtine change on normal file in /root IS reported




Additional info:

The problem lies in the last rule in the configuration file.

it is curretnly

/root/.* PERMS

however since aide treats the lines a regular expressions, not globs, this matches all files in /root.

/root/\..* PERMS

Fixes the problem.
Comment 1 Steve Grubb 2009-08-19 17:51:29 EDT
A new aide package has been built in rawhide to address this issue. Thanks for reporting it.

Note You need to log in before you can comment on or make changes to this bug.