Bug 509371 - SSM->Verify page displays the packages as package.arch and there is a separate Architecture column.
SSM->Verify page displays the packages as package.arch and there is a separat...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Preethi Thomas
https://rlx-3-24.rhndev.redhat.com/rh...
:
Depends On:
Blocks: 471789
  Show dependency treegraph
 
Reported: 2009-07-02 10:03 EDT by Preethi Thomas
Modified: 2009-09-10 14:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:45:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SSM->Verify page (158.73 KB, text/plain)
2009-07-02 10:03 EDT, Preethi Thomas
no flags Details
SSM->Verify page (158.73 KB, image/png)
2009-07-02 10:24 EDT, Preethi Thomas
no flags Details

  None (edit)
Description Preethi Thomas 2009-07-02 10:03:46 EDT
Created attachment 350273 [details]
SSM->Verify page

Description of problem:

SSM->Verify page displays the packages as package.arch and there is a separate Architecture column.
Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090625.0-i386-embedded-oracle.iso

How reproducible:


Steps to Reproduce:
1. select an X86-64 system
2. go to SSM->Verify
3. 
  
Actual results:
screen shot attached

Expected results:
package should be displayed without 

Additional info:
Comment 1 Preethi Thomas 2009-07-02 10:24:36 EDT
Created attachment 350285 [details]
SSM->Verify page
Comment 2 Brad Buckingham 2009-07-02 15:45:28 EDT
master git commit: 0371776775b3aaa5fc3933eeb6a96e514acf12bb
vader git commit: 2cf2a100933105154cde877670743aa63ac3d63f

Updated the SSM->Verify to drop the redundant arch from the "Package Name", since there is already a separate "Architecture" column.

SSM->Remove actually uses the same query; therefore, it also fixes the same problem on that page.

SSM->Install -> While testing, I found that this one also had 2 similar problems and fixed those as well.  1) the Architecture column contained AMD vs x86_64 (i.e. it wasn't using rhnPackageArch.label), so fixed that... and 2) the "Package Name" column was including the redundant arch in the name; therefore, dropped it to be consistent w/ the SSM->Verify and SSM->Remove changes above.
Comment 3 Preethi Thomas 2009-07-07 10:29:58 EDT
verified
Satellite-5.3.0-RHEL5-re20090702.0-i386-embedded-oracle.iso
ssm->verify no arch name with packages
SSM-> Install Architecture contains X86_64 and not AMD and package name does not have the architecture with it
ssm->Remove no arch name with packages
Comment 4 Jeff Browning 2009-08-09 14:06:02 EDT
Tested on test1182.test.redhat.com
Comment 5 Brandon Perkins 2009-09-10 14:45:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.